PowerProtect:處理要求時,Cloud Snapshot Manager 複製工作失敗,並出現錯誤

Summary: PowerProtect:Cloud Snapshot Manager 複製工作失敗,並顯示錯誤:{“錯誤”:[{“代碼”:1004,“消息”:“處理請求時遇到錯誤。”,“詳細資訊”:“處理請求時遇到錯誤。”}]}

Ez a cikk a következő(k)re vonatkozik: Ez a cikk nem vonatkozik a következő(k)re: Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem. Ez a cikk nem azonosítja az összes termékverziót.

Symptoms

將快照從 Amazon Web Services (AWS) 複製到 Data Domain Virtual Edition (DDVE) 的複製工作失敗,並出現類似以下的錯誤訊息:
"Error occured fetching session from csm proxy : Error: {"errors":[{"code":1004,"message":"Error encountered while processing the request.","details":"Error encountered while processing the request."}]} Error code: 3041"
沒有 AWS ECS 集群,任務定義已在 AWS 帳戶中創建。

AWS CloudFormation 記錄會顯示類似以下內容的錯誤訊息:
# TaskDefinition CREATE_FAILED
Resource handler returned message: "Invalid request provided: Create TaskDefinition: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:task-definition/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyTaskDefinition:* because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)" (RequestToken: 0d5dea1c-e158-e5e2-0080-1e2c521679dc, HandlerErrorCode: InvalidRequest)
此時會看到類似以下內容的訊息:
# Cluster CREATE_FAILED
Resource handler returned message: "Error occurred during operation 'CreateCluster SDK error: User: arn:aws:sts::sideID:assumed-role/CSMRole/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx is not authorized to perform: ecs:TagResource on resource: arn:aws:ecs:ZONE:sideID:cluster/csm-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx_proxyCluster because no identity-based policy allows the ecs:TagResource action (Service: AmazonECS; Status Code: 400; Error Code: AccessDeniedException; Request ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx; Proxy: null)'." (RequestToken: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, HandlerErrorCode: GeneralServiceException)

Cause

AWS 權限 ecs:TagResource 在分配給雲快照管理器使用的角色的 IAM 策略中丟失。

Resolution

更新分配給 Cloud Snapshot Manager 所用角色的 IAM 原則。

以下文件連結可用於尋找有關如何建立或更新 IAM 策略的步驟:PowerProtect Cloud Snapshot Manager 線上說明 |Dell US

JSON 標籤下進行變更,如下圖所示:

CSM 原則變更以新增 esc:TagResource 權限。

Érintett termékek

Cloud Snapshot Manager, PowerProtect Cloud Snapshot
Termék tulajdonságai
Article Number: 000223744
Article Type: Solution
Utoljára módosítva: 29 aug. 2025
Version:  2
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.