PowerStore: Pre-Upgrade Health Check (PUHC) und System Health Check (SHC), um zu erkennen, ob eine Volume-Gruppe ohne Mitglieder vorhanden ist

Summary: Diese Prüfungen dienen dazu, alle Volume-Gruppen ohne Mitglieder zu finden oder ob Volumes mit internen Attributen vorhanden sind, die Anlass zur Sorge geben. Die PUHC-Prüfung (empty_vg_no_members) soll das Upgrade auf PowerStoreOS 4.0.x beenden, wenn dieses Problem festgestellt wird. Die SHC-Prüfung (invalid_vg_uuid_check) schlägt fehl, wenn dieses Problem auf einem Cluster mit PowerStoreOS 4.0.x auftritt. ...

Ez a cikk a következő(k)re vonatkozik: Ez a cikk nem vonatkozik a következő(k)re: Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem. Ez a cikk nem azonosítja az összes termékverziót.

Symptoms

PowerStore Pre-Upgrade Health Check (PUHC) und System Health Check (SHC) erkennen dieses Problem möglicherweise, wenn sie auf den folgenden PowerStoreOS-Versionen ausgeführt werden:

  • PowerStoreOS 3.x
  • PowerStoreOS 4.x

Szenario 1:
Beim Ausführen des Health Check vor dem Upgrade (PUHC) wird möglicherweise die folgende Meldung vor einem Upgrade auf PowerStoreOS 4.0.x angezeigt:

  • Die Integritätsprüfung vor dem Upgrade (Pre-Upgrade Health Check, PUHC) gibt möglicherweise die folgende Meldung zurück:
    Exists volume groups with no members. Please delete those volume groups and then add them back after NDU. KB # 000238653 (empty_vg_no_members).
    PUHC-Prüfung für leere Volume-Gruppe
  • Diese PUHC-Prüfung schlägt fehl, wenn eine Volume-Gruppe vorhanden ist und null (0) Mitglieds-Volumes aufweist
    • Informationen zu Korrekturmaßnahmen finden Sie im Abschnitt "Lösung" dieses Wissensdatenbank-Artikels.
  • Ein unterbrechungsfreies Softwareupgrade (NDU) kann nicht fortgesetzt werden.

Szenario 2:
Beim Ausführen der PowerStore-Systemintegritätsprüfung (SHC) wird möglicherweise die folgende Meldung auf einem PowerStoreOS 4.0.x-Cluster angezeigt:

  • Die Systemintegritätsprüfung (System Health Check, SHC) gibt möglicherweise die folgende Meldung zurück:
    Found problematic attributes in volume groups. (KB#000238653).
    invalid_vg_uuid_check SHC-Prüfung fehlgeschlagen
  • Wenn der System-Health-Check (SHC)-Test über die Befehlszeilenschnittstelle (CLI) ausgeführt wird, wird möglicherweise Folgendes angezeigt:
    [SVC:service@123456-A ~]$ svc_health_check run -rhc invalid_vg_uuid_check
    Name                               Location  Status     Description
    Invalid Volume Group UUID Check    node_a    Failed     Found problematic attributes in volume groups. (KB#000238653)
     
     
    SUMMARY Status: Failed
       Passed:      0
       Failed:      1
       Total:       1
    Hinweis: Die Ergebnisse können von den oben genannten abweichen, je nachdem, bei welchen Nodes der Test fehlgeschlagen ist.
  • Diese SHC-Prüfung schlägt fehl, wenn eine Volume-Gruppe mit einer ungültigen UUID vorhanden ist.
  • Informationen zu Korrekturmaßnahmen finden Sie im Abschnitt "Lösung" dieses Wissensdatenbank-Artikels.

Bei diesen Integritätsprüfungen handelt es sich um PUHC- und SHC-Prüfungen außerhalb der Version, die im Integritätsprüfungs-Thin-Paket enthalten sind, das von der Dell Website Treiber und Downloads heruntergeladen werden kann. Weitere Informationen zum Thin-Paket zum Health Check finden Sie im Abschnitt Zusätzliche Informationen.

 

Cause

Volume-Gruppen sind eine neue Funktion in System Manager (SYM). Wenn eine Volume-Gruppe ohne Mitglieder im Kontrollpfad (CP) vorhanden ist, behält sie eine All-Zero-Kennung bei. Diese ungültige Kennung kann zu Problemen beim späteren Hinzufügen oder Entfernen von Volume-Mitgliedern führen.

 

Resolution

Szenario 1:
Wenn die Integritätsprüfung vor dem Upgrade (Pre-Upgrade Health Check, PUHC) eine Meldung ausgibt, dass Volume-Gruppen ohne Mitglieder auf einem PowerStoreOS 3.x- oder 4.x-Cluster vorhanden sind:

  • Diese Meldung weist darauf hin, dass Volume-Gruppen mit null (0)Mitglieds-Volumes auf dem PowerStore-Cluster vorhanden sind.
  • Navigieren Sie in PowerStore Manager zu Storage > Volume Groups und suchen Sie nach allen Volume-Gruppen , die null (0)Mitglieds-Volumes haben.
    Bildschirm
  • Wählen Sie alle Volume-Gruppen mit null (0) Mitglieds-Volumes aus, klicken Sie auf das Dropdown-Menü Weitere Aktionen und wählen Sie Löschen aus.
    Bildschirm
  • Nachdem alle Volume-Gruppen mit null (0) Mitglieds-Volumes gelöscht wurden, fahren Sie mit dem unterbrechungsfreien Softwareupgrade (NDU) fort.

Szenario 2:
Wenn die Systemintegritätsprüfung (System Health Check, SHC) die Meldung "Problematische Attribute in Volume-Gruppen gefunden" ausgibt. (KB#000238653) auf einem PowerStoreOS 4.0.x-Cluster:

  • Diese Meldung gibt an, dass eine Volume-Gruppe mit null (0) Mitglieds-Volumes auf einem PowerStoreOS 3.x-Cluster vorhanden war und später auf PowerStoreOS 4.0.x aktualisiert wurde.
    • Nach dem Softwareupgrade auf PowerStoreOS 4.0.x wurden dieser Volume-Gruppe Volumes hinzugefügt, die zuvor null (0) Mitglieds-Volumes hatten.
    • Durch diese Reihe von Administrationsmaßnahmen wurde möglicherweise eine ungültige UUID für das PowerStore-Cluster von 00000000000000000000000000000000000000000 ungültige UUID in das PowerStore-Cluster eingeführt.
    • Um dieses Problem zu beheben, wenden Sie sich an den technischen Support , um Unterstützung zu erhalten. Lesen Sie KB # 000238653 für schnellere Bearbeitung und Lösung.

 

Additional Information

Weitere Informationen zum Health Check Thin Package finden Sie im Wissensdatenbankartikel 000192601 PowerStore: Anleitung zum Überprüfen der Integrität des Clusters vor dem Softwareupgrade mithilfe der Integritätsprüfung vor dem Upgrade und der Systemprüfung

Weitere Informationen zu allen Integritätsprüfungen im Integritätsprüfungs-Thin-Paket finden Sie unter KB# 000214752 PowerStore: Landingpage für Systemintegritätsprüfungen (außerhalb der Version)

 

Érintett termékek

PowerStore
Termék tulajdonságai
Article Number: 000238653
Article Type: Solution
Utoljára módosítva: 14 jún. 2025
Version:  10
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.