PowerScale: Isilon: Brug af sudo-konto efter opgradering mislykkes med "USER er ikke i sudoers-filen. Denne hændelse er rapporteret." (Kan rettes af brugeren)

요약: Sudo-konti i et begrænset antal OneFS-versioner blev oprettet ved hjælp af en løsning. Når klyngen opgraderes til en OneFS-kodeversion, hvor problemet blev løst, fungerer disse sudo-konti ikke korrekt. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Koden blev opgraderet fra en version af OneFS, hvor isi_visudo ikke arbejdede på en nyere version af OneFS, hvor isi_visudo blev rettet.

sudo konti, der er oprettet på en OneFS-version med en defekt isi_visudo Oplevede fejl med sudo efter opgradering til en korrekt kodeversion (f.eks. v8.1.0.4). Trods sudo kontoposteringer, der bekræftes i /etc/mcp/override/sudoers og /usr/local/etc/sudoers—som kræver root adgang—sudo fungerede ikke korrekt.

Mere output fra den ikke-fungerende sudo-konto kan se ud som følgende output ud over USERNAME is not in the sudoers file fejl:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

원인

Problemet er relateret til OneFS-koden.

해결

Log på som ikonet root bruger, og:

  1. Brug
    isi_visudo
    og slet den USER-konto, der blev konfigureret til sudo. Vær forsigtig med kun at slette sudo konto, der ikke fungerer. Gem filen. 
    :wq!
  2. Brug
    isi_visudo
    og genoprette USER-kontoen med de korrekte indstillinger. Gem filen.

Kodeopgraderingen bør ikke påvirke rollerne og andre godkendelser. Brugerkontoen og adgangskoden forbliver uændrede. Når du har udført ovenstående trin, fungerer kontoen igen.

해당 제품

Isilon

제품

Isilon, PowerScale OneFS
문서 속성
문서 번호: 000059475
문서 유형: Solution
마지막 수정 시간: 01 4월 2025
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.