PowerScale: Isilon: Bruk av sudo-konto etter oppgradering mislykkes med "BRUKEREN er ikke i sudoers-filen. Denne hendelsen er anmeldt.» (Kan rettes opp av bruker)

요약: Sudo-kontoer i et begrenset antall OneFS-versjoner ble opprettet ved hjelp av en midlertidig løsning. Når klyngen oppgraderes til en OneFS-kodeversjon der problemet ble løst, fungerer ikke disse sudokontoene som de skal. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Koden ble oppgradert fra en versjon av OneFS der isi_visudo ikke fungerte til en nyere versjon av OneFS der isi_visudo ble fikset.

sudo kontoer opprettet på en OneFS-versjon med en defekt isi_visudo opplevde feil med sudo etter oppgradering til en korrigert kodeversjon (for eksempel v8.1.0.4). Tross sudo Kontooppføringer bekreftes i /etc/mcp/override/sudoers og /usr/local/etc/sudoers– som krever root tilgang—sudo fungerte ikke som den skulle.

Mer utdata fra den ikke-fungerende sudo-kontoen kan se ut som følgende utdata, i tillegg til USERNAME is not in the sudoers file feil:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

원인

Problemet er relatert til OneFS-koden.

해결

Logg på som root bruker, og:

  1. Bruk
    isi_visudo
    og slette BRUKERKONTOEN som ble satt opp for sudo. Vær forsiktig bare for å slette sudo konto som ikke fungerer. Lagre filen. 
    :wq!
  2. Bruk
    isi_visudo
    og gjenopprett BRUKERKONTOEN med de riktige innstillingene. Lagre filen.

Kodeoppgraderingen skal ikke påvirke rollene og andre autorisasjoner. Brukerkontoen og passordet forblir uendret. Etter å ha utført trinnene ovenfor, vil kontoen fungere igjen.

해당 제품

Isilon

제품

Isilon, PowerScale OneFS
문서 속성
문서 번호: 000059475
문서 유형: Solution
마지막 수정 시간: 01 4월 2025
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.