NetWorker: NMM 19.x Zálohování SQL AlwaysOn nereaguje a zvyšuje výkon serveru
요약: Zálohování NetWorker NMM 19.x SQL AlwaysOn nereaguje a zvyšuje výpočetní výkon serveru. Záloha SQL nepokračuje a zdá se, že přestala reagovat.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
Při upgradu serveru NetWorker z verze 18.x na verzi 19.x byly zaznamenány určité výskyty.
Zálohy databáze skupiny AlwaysOn Availability systému SQL Server pomocí modulu NetWorker Module for Microsoft (NMM) vykazují tyto příznaky:
- Zálohování AlwaysOn nereaguje. Ve skutečnosti je příkaz "nsrsqlsv" spuštěn příkazem savefs, ale nikdy nezačne ukládat žádná data.
- Ovlivňuje zálohování AlwaysOn (AOAG) SQL Serveru přes klienta clusteru
- Zálohy databáze pro samostatné instance SQL Server ve stejném clusteru AlwaysOn nemají žádné problémy se zálohováním databáze SQL.
- V serveru NetWorker dochází k výrazným špičkám v procesoru. To může být doprovázeno závažným snížením výkonu jiných spuštěných úloh zálohování.
원인
Toto chování může způsobit několik faktorů v nastavení a příčina může být přičítána více než jednomu jedinému faktoru.
Mezi faktory patří.
- Upgrade: Server NetWorker byl nedávno upgradován. Před upgradem byly úlohy v pořádku. V jednom příkladu byl server upgradován z verze 18.x na verzi 19.2 a byly upgradovány také klienti SQL NetWorker a NMM.
- Záznamy z databáze médií: Analýza serveru může najít mnoho klientů bez sad uložení a/nebo nekonzistentní záznamy databáze médií pro některé sady uložení. Tyto sady uložení mohou, ale nemusí souviset s dotčeným klientem SQL.
- Vyčistěte databázi médií různými metodami, například
nsrim -X -Vnevyřeší problém. - Klientský index: Existuje podezření na poškození skutečného indexu klientských souborů klienta clusteru. Tento poslední krok může vyžadovat přejmenování indexu klientských souborů.
해결
Klient clusteru SQL pro AlwaysOn je klient, který zálohuje uloženou sadu, která vypadá takto: MSSQL#AAG:
Example MSSQL#ALWAYS_ON_GROUP_NAME:
Tyto kroky proveďte, pokud pro klienta clusteru SQL nejsou spuštěny žádné úlohy zálohování.
- Přejmenujte index klientských souborů klienta clusteru.
- Příklad: Přejmenujte složku "/nsr/index/CLUSTER_CLIENT_NAME" na "/nsr/index/CLUSTER_CLIENT_NAME.suspect".
- Spusťte novou zálohu clusterového klienta SQL AlwaysOn.
- Vygeneruje se nový index a zálohování by mělo být úspěšné.
문서 속성
문서 번호: 000070286
문서 유형: Solution
마지막 수정 시간: 20 1월 2026
버전: 5
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.