CloudIQ: Unisphere for PowerMax: Unable to view just performance data in CloudIQ. It shows "No data to display".

요약: Unable to view just performance data in CloudIQ. It shows "No data to display".

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증상



Unable to view performance data only in CloudIQ. It shows "No data to display".

All other data collecting in CloudIQ is ok.
 
kA23a000000GHbECAW_3_0

The collection.log and smas.log is streaming with status code: 400 errors but that does not indicate the actual failure.

The actual failure is found in the smas.log. See below snippet:    
 
2020-01-17 08:28:48,676 ERROR [org.jboss.as.ejb3.invocation] (EE-ManagedThreadFactory-default-Thread-6) WFLYEJB0034: EJB Invocation failed on component MetricsDateManager for method public abstract com.emc.em.common.collector.persistence.MetricsCollectionPeriod com.emc.em.collector.impl.util.IMetricsDateManager.getMetricsCollectionPeriod(): javax.ejb.EJBException: java.lang.RuntimeException: com.emc.em.common.persistence.PersistenceException: java.io.EOFException

원인

MetricsDateManager file is corrupted. That is the file that the SPA (metrics) data is written to.

해결

Follow the steps below to address the issue:     
  1. Stop Unisphere server
  2. Rename the file:     
<SMAS>\ jboss\standalone\data\esrs\MetricsDateManager.pers
to
MetricsDateManager_backup.pers
  1. Restart the Unisphere server.
Restarting the server re-triggers metrics and a fresh file should be recreated. It can take about 5-6 minutes for the new file to be created.

해당 제품

CloudIQ

제품

CloudIQ, Unisphere for PowerMax
문서 속성
문서 번호: 000081995
문서 유형: Solution
마지막 수정 시간: 25 4월 2025
버전:  3
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