Avamar:複製失敗,並出現內部循環錯誤

요약: Avamar 複寫失敗,並出現 avtar 錯誤 <5445>:內部週期錯誤:在 repldata DST_ADD_DATA 中回應不佳:ADD_HASH_DATA=2 和“MSG_ERR_INVALID_PARAMETERS”

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Avamar 格線在為一或多個用戶端複製備份時可能會發生問題。

此特定情況是在 VSphere Data Protection (VDP) 系統上發生。可使用 vdp-client-activity.log 提供下列資訊: 

2016-10-03 04:11:03 avtar Info <6654>: Replicating backup 244, Label "somebackup-1475002800005", 26.27 GB 
2016-10-03 04:16:01 avtar Info <8688>: Status 2016-10-03 04:16:01, 26.00 GB (0 bytes, 0.00% new) 638MB 0% CPU client04_UATRUr8adn0H5ZysJuc9xw#244::/VMFiles/1/ 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp06.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:21:01 avtar Info <8688>: Status 2016-10-03 04:21:01, 26.00 GB (0 bytes, 0.00% new) 638MB 0% CPU client04_UATRUr8adn0H5ZysJuc9xw#244::/VMFiles/1/ 
2016-10-03 04:21:03 avtar Error <5445>: INTERNAL CYCLE ERROR: bad response in repldata DST_ADD_DATA: ADD_HASH_DATA=2 serial=114 seq=0 flags=R:N:1 kind=7 rsp=MSG_ERR_INVALID_PARAMETERS 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:16:04 avtar Info <7694>: Server(vdp06.customer.com) not responding (possible network congestion?) (300 seconds) 
2016-10-03 04:47:43 avtar Info <7694>: Server(vdp05.customer.com) not responding (possible network congestion?) (300 seconds) 

원인

重複的消息「可能的網路擁塞」並不一定意味著存在連接問題。它們指示目標網格未以預期方式回應。

錯誤訊息提供更多資訊,指出來源網格要求ADD_DATA到目的地 VDP 時發生問題」DST_ADD_DATA: ADD_HASH_DATA=2.」

在調查此問題時,無法找出問題的根本原因。」MSG_ERR_INVALID_PARAMETERS」但是,關鍵詞「內部週期錯誤」表示潛在的用戶端快取損壞。

해결

下列方法可用於解決此行為。
(如果這種情況重複發生,請聯絡 Dell Technologies 支援小組。)

1.列出其備份失敗並出現上述錯誤的用戶端。

2.複製現有的複製組以創建「測試」複製組。或者,暫時修改現有的複製組,並確保它僅包含有問題的用戶端。

3.建立或編輯檔案 /usr/local/avamar/var/client/avtar.cmd  在源網格上。

4.新增項目”--nocache'。

這可防止複製作業利用用戶端快取檔。

如果用戶端快取已損壞,不使用它們可以確定它們是否是複製失敗的原因。

5.執行包含「問題用戶端」的複寫工作,並允許其完成。

如果複製失敗,本文將不適用,需要進一步調查。 

如果複製成功,則必須為有問題的用戶端重新生成用戶端緩存。

6.重新產生用戶端快取:

一個。編輯 /usr/local/avamar/var/client/avtar.cmd 再。

b.刪除”--nocache“ 輸入並將其替換為”--clearcache」。

7.重新運行測試複製組,以便重新創建用戶端緩存。等待工作完成。

8.刪除 avtar.cmd 檔案或編輯 usr/local/avamar/var/client/avtar.cmd 並刪除”--clearcache'條目。  

警示:不要錯過此步驟,否則將為所有用戶端重新生成緩存,並且下一次複製將非常耗時。
 

9.還原至包含所有必須複製之用戶端的原始複寫群組組態。

10.允許正常執行排定的複寫。重新生成緩存的客戶端現在應進行複製。

해당 제품

Avamar

제품

Avamar, Avamar Server
문서 속성
문서 번호: 000165660
문서 유형: Solution
마지막 수정 시간: 13 10월 2025
버전:  8
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.