NetWorker: funkcja FLR vProxy kończy się niepowodzeniem z błędem "Nie udało się zalogować do usługi Data Domain"

요약: Niepowodzenie funkcji FLR vProxy z błędem "Failed to log in to Data Domain service"

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

NetWorker VMware Protection (NVP) FLR kończy się niepowodzeniem, zgłaszając błąd "Nie udało się zalogować do usługi Data Domain"

Zasoby systemów NetWorker Data Domain są skonfigurowane z odpowiednim użytkownikiem na poziomie administratora dla Data Domain:

Użytkownik Data Domain Management

UWAGA: Użytkownik zarządzania musi być użytkownikiem na poziomie administratora domeny danych, na przykład: sysadmin. Hasło musi być poprawne. Sprawdź, czy możesz zalogować się do interfejsu sieciowego zarządzania Data Domain jako sysadmin. Jeśli zalogowano się pomyślnie, zaktualizuj pole "hasło zarządzania" dla Data Domain w NetWorker, aby upewnić się, że ustawiono prawidłowe hasło.

Dzienniki sesji instalacji FLR vProxy pokazują "połączenie zresetowane przez peera"

  • /opt/emc/vproxy/runtime/logs/recycle/vflrd/DATE/mount-SESSION-ID.log
2020-05-04T17:38:40Z INFO: [@(#) Build number: 117] Unmounting after mount failure: Unable to create NFS export at '[DD_FQDN]:/data/col1/[NW_FQDN]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Unable to login while creating NFS export at '[DD_FQDN]:/data/col1/[NW_NAME]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Failed to login to DataDomain service at 'https://[DD_NAME]:3009/rest/v1.0/auth': Post https://[DD_FQDN]:3009/rest/v1.0/auth: read tcp []->[]:3009: read: connection reset by peer

Czasami vProxy może nawiązać połączenie z Data Domain, ale jego host ESXi nie, co powoduje problemy z łącznością. Interfejs ESXi nc (netcat) można użyć do sprawdzenia komunikacji portu z DD:

nc -zv DD_HOSTNAME PORT
 

원인

Składnik sieci lub zapora uniemożliwia połączenie, co powoduje wyświetlenie komunikatu o błędzie "połączenie zresetowane przez element równorzędny".

해결

Skontaktuj się z zespołem ds. sieci lub zapory internetowej w sprawie problemu z połączeniem.

Do zidentyfikowania miejsca występowania problemu można użyć następujących danych wyjściowych:

  1. Z poziomu vProxy użyj poleceń curl, aby sprawdzić, czy można połączyć się z portami 22, 2049, 2052 i 3009 na DD:
curl -v DD_HOSTNAME:PORT
  1. Z poziomu vProxy sprawdź, czy vProxy może nawiązać połączenie SSL z DD:
curl -kv https://DD_HOSTNAME:3009/rest/v1.0/trust
UWAGA: Oczekuje się, że dane wyjściowe tego polecenia zwrócą certyfikat SSL z podpisem własnym używany do łączenia się z Data Domain.
  1. W konsoli głównej vProxy uruchom tcpdump:
UWAGA: Nie możesz połączyć się bezpośrednio z vProxy przez SSH jako użytkownik root. Otwórz sesję SSH i zaloguj się jako administrator. Przełączenie się na użytkownika root za pomocą sudo su -.

tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap

  • -i określa interfejs, możesz użyć dowolnego lub określić nazwę interfejsu sieciowego systemu, na przykład eth0.
  • -s 0 Określa długość przyciągania 65535 (przechwytywana jest cała klatka).
  • -C 500 wskazuje rozmiar pliku 500 000 000 bajtów.
  • -w wskazuje lokalizację pliku wyjściowego. Wyświetlany plik wyjściowy jest generowany automatycznie z nazwą hosta systemowego i RRRR-MM-DD, że został uruchomiony. 
  1. Z poziomu NMC zainicjuj montaż FLR. W przypadku zaobserwowania problemu zatrzymaj tcpdump (CTRL+C) i przejrzyj sygnaturę czasową .pcap z katalogu /tmp w przypadku problemów z połączeniem.
UWAGA: Plik .pcap można analizować w programie Wireshark. Wireshark (WiresharkKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.) to narzędzie innej firmy służące do analizowania przechwytywania pakietów. Skontaktuj się z administratorem sieci, aby uzyskać pomoc dotyczącą przechwytywania pakietów. 
  1. Z poziomu hosta hosta ESXi vProxy używanego do FLR (widocznego w VMware) sprawdź, czy host ESXi może osiągnąć porty 22, 2049, 2052, 3009 na DD.
nc -zv DD_HOSTNAME PORT

추가 정보

해당 제품

NetWorker

제품

NetWorker Family
문서 속성
문서 번호: 000173057
문서 유형: Solution
마지막 수정 시간: 14 8월 2025
버전:  5
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.