Kan ikke binde LDAP'er i Dell Security Management Server Virtual 11.0 eller nyere

요약: Denne artikel beskriver en situation, hvor Dell Security Management Server Virtual v11.0 og nyere modtager fejlen "Kan ikke oprette forbindelse til serveren", når der tilknyttes LDAP'er i Remote Management Console. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Berørte produkter:

  • Dell Security Management Server Virtual

Berørte versioner:

  • v11.0 og nyere

Påvirkede operativsystemer:

  • Linux

Ses typisk efter opgradering til Dell Security Management Server Virtual v11.0 eller nyere fra en ældre version og forsøg på at bruge de samme LDAPs-indstillinger, der fungerede fint, før opdateringen nu viser en dårlig status for domænet, og der opstår fejl, når du forsøger at gemme LDAPs-indstillinger.

Der vises en fejl om, at det ikke er muligt at oprette forbindelse til serveren, når du forsøger at binde LDAP'er i fjernadministrationskonsollen. Logfiler viser SSL-handshake-fejl:

org.springframework.ldap.CommunicationException: simple bind failed: ADSERVER.DOMAIN.COM:636; nested exception is javax.naming.CommunicationException: simple bind failed: ADSERVER.DOMAIN.COM:636 [Root exception is javax.net.ssl.SSLHandshakeException: No subject alternative DNS name matching ADSERVER.DOMAIN.COM found.]

Kan ikke oprette forbindelse til serveren
Figur 1: (Kun på engelsk) Kan ikke oprette forbindelse til serveren

원인

Selvafsendede certifikater og Java-opdateringerne i v11.0. Slutpunktsidentifikationsalgoritmer er aktiveret som standard for at forbedre robustheden af LDAPS-forbindelser (secure LDAP over TLS). Fra changelog: https://www.oracle.com/technetwork/java/javase/8u181-relnotes-4479407.html Dette hyperlink fører dig til et websted uden for Dell Technologies.

해결

Deaktiver slutpunktsidentifikation ved at ændre wrapper.conf ved at følge instruktionerne nedenfor.

Bemærk: Denne handling kan udføres via SSH-session, hvis det ønskes. Sådan aktiveres SSH: Sådan aktiveres SSH i Dell Security Management Server Virtual/Dell Data Protection Virtual Edition
  1. Stop services refererer til Sådan stopper og starter du tjenester i Dell Security Management Server Virtual/Dell Data Protection Virtual Edition.
  2. I hovedmenuen skal du vælge Launch Shell:

Vælg Launch Shell (Start shell)
Figur 2: (Kun på engelsk) Vælg Launch Shell (Start shell)

  1. Skriv su dellsupport og tryk på Enter:

Skriv su dellsupport
Figur 3: (Kun på engelsk) Type su dellsupport

  1. Indtast adgangskoden til dellsupport konto, og tryk på Enter:

Indtast adgangskoden
Figur 4: (Kun på engelsk) Indtast adgangskoden

  1. Skriv sudo nano /opt/dell/server/security-server/conf/wrapper.conf.

Skriv sudo nano /opt/dell/server/security-server/conf/wrapper.conf
Figur 5: (Kun på engelsk) Type sudo nano /opt/dell/server/security-server/conf/wrapper.conf

  1. Under # Additional java parameters to the VM, add the line (Antal ekstra javaparametre til VM' er) skal du tilføje linjen wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true hvor XX er trinvist hen til listen (min er 12 i dette eksempel):

Tilføj line wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true
Figur 6: (Kun på engelsk) Tilføj linje wrapper.java.additional.XX=-Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true

  1. Tryk på CTRL + O for at gemme ændringerne.
  2. Tryk på CTRL + X for at afslutte.
  3. Skriv exit og derefter trykke på Enter for at logge ud af dellsupport.

Skriv exit
Figur 7: (Kun på engelsk) Type exit

  1. Skriv exit og derefter trykke på Enter for at logge ud af shell'en til hovedmenuen.

Skriv exit
Figur 8: (Kun på engelsk) Type exit

  1. Startservices refererer til Sådan stopper og starter du tjenester i Dell Security Management Server Virtual/Dell Data Protection Virtual Edition.

Nu kan du binde domænet ved hjælp af LDAPs-porten.

해당 제품

Dell Encryption
문서 속성
문서 번호: 000205453
문서 유형: Solution
마지막 수정 시간: 15 11월 2023
버전:  2
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.