CloudLink: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

요약: CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

  • CloudLink agent is not upgraded automatically after CloudLink cluster has been upgraded to a new version.
  • All agent policies are set to Automatic upgrade.
  • Following the CloudLink server upgrade to version 7.1.5, no agent was upgraded and all agents report version as 7.1.133.
  • Tried to set a policy to manual upgrade in order to upgrade the agent manually, but the upgrade option is unavailable for all agents even if the policy is manual.
  • Uninstalled the agent on one of the protected VMs and installed the agent again. It was showing the original agent version of 7.1.133

원인

Working as designed.
Occasionally the same agent is used for versions of two releases.
Occasionally there is a difference in Linux agent version but no change for Windows agent.

해결

This is working as designed. Check the customer's agent Operating System type, CloudLink source code, and destination code version to check if the agent version must be upgraded.

In this instance, the agent version does not need to be upgraded if the current version matches the mapping matrix as below:
CloudLink Version      Windows Agent        Linux Agent
CloudLink 7.1.1 7.1 (build 9) 7.1 (build 32)
CloudLink 7.1.2 7.1 (build 111) 7.1 (build 111)
CloudLink 7.1.3 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.4 7.1 (build 133) 7.1 (build 136)
CloudLink 7.1.5 7.1 (build 133) 7.1 (build 140)
CloudLink 7.1.6 7.1 (build 133) 7.1 (build 140)

제품

CloudLink
문서 속성
문서 번호: 000212227
문서 유형: Solution
마지막 수정 시간: 17 5월 2026
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.