NetWorker: Azure-Abonnement fehlt in NWUI

요약: Ein Microsoft Azure-Abonnement wurde zuvor zu NetWorker hinzugefügt. Das Azure-Abonnement wird in der NetWorker-Webnutzeroberfläche (NWUI) nicht angezeigt. Beim Versuch, das Azure-Abonnement erneut hinzuzufügen, wird ein Fehler angezeigt, der besagt, dass das Azure-Abonnement bereits in NetWorker vorhanden ist. Das Abonnement wird über eine nsradmin-Eingabeaufforderung auf dem NetWorker-Server angezeigt. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Dem NetWorker-Server wurde zuvor ein Azure-Abonnement hinzugefügt. Die NetWorker-Webnutzungsschnittstelle (NWUI) zeigt keine Azure-Abonnements an:

NWUI-Azure-Abonnements

Beim Versuch, das Azure-Abonnement wieder zu NetWorker hinzuzufügen, wird gemeldet, dass es bereits vorhanden ist:

Azure-Abonnement bereits vorhanden

Die daemon.log des NetWorker-Servers meldet möglicherweise:

66113 MM/DD/YYYY HH:mm:SS  nsrd NSR critical Failed to retrieve item _azure_AZURE_SUBSCRIPTION_NAME_client secret from lockbox /nsr/lockbox/NETWORKER_SERVER_FQDN/clb.lb

Das Azure-Abonnement wird über eine nsradmin Eingabeaufforderung auf dem NetWorker-Server:

  1. Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten auf dem NetWorker-Server.
  2. Führen Sie folgenden Befehl aus: nsradmin
  3. Listen Sie in der Eingabeaufforderung von nsradmin die Azure-Abonnements auf: print type: NSR Azure Subscription
azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p type: NSR Azure Subscription
                        type: NSR Azure Subscription;
                        name: SUBSCRIPTION-RESOURCE-NAME;
                     comment: ;
                   tenant id: AZURE-TENANT-ID;
             subscription id: AZURE-SUBSCRIPTION-ID;
                   client id: AZURE-CLIENT-IDb;
               client secret: *******;
                    endpoint: management.azure.com;
                     command: nsrazure_discovery;
               administrator: "user=root,host=azure-nve.local",
                              "user=administrator,host=azure-nve.local",
                              "user=system,host=azure-nve.local",
                              "user=nsrnmc,host=azure-nve.local",
nsradmin> quit
HINWEIS: Wenn das Azure-Abonnement nicht in der NetWorker-Serverressourcendatenbank (NSRDB) aufgeführt ist, ist dieser Wissensdatenbank-Artikel nicht anwendbar. Dieser Wissensdatenbank-Artikel gilt nur, wenn die Ressource noch in der NSRDB vorhanden ist, aber nicht in der NWUI oder NMC angezeigt wird.

원인

Es gibt mehrere Probleme, die diese Symptome verursachen können.
  • Die Lockbox des NetWorker-Servers ist beschädigt.
  • NetWorker ist nicht in der Lage, den geheimen Clientschlüssel des Azure-Abonnements aus der Lockbox zu entschlüsseln.
  • Für den geheimen Azure-Clientschlüssel wurde bei der Erstellung ein Ablaufzeitraum definiert. Das Ablaufdatum ist verstrichen und der in der NetWorker-Azure-Abonnementressource verwendete geheime Clientschlüssel ist nicht mehr gültig.

해결

WARNUNG: Befolgen Sie diesen Wissensdatenbank-Artikel nur, wenn Azure-Abonnements auf dem NetWorker-Server vorhanden sind, aber in der NWUI nicht sichtbar sind . Wenn die Abonnements bereits in der NWUI sichtbar sind, wenden Sie dieses Verfahren nicht an – andernfalls wird die Konfiguration unterbrochen und die Abonnements werden von der NWUI nicht mehr angezeigt.

 

  1. Erstellen Sie auf dem NetWorker-Server eine Datei mit dem Namen clear_client_secret.txt an einem Ort Ihrer Wahl.
  2. Fügen Sie der Datei die folgenden Inhalte hinzu und speichern Sie sie:
. type: nsr azure subscription
update client secret: ;
y
  1. Beenden Sie über eine Root-Shell (Linux) oder Administrator-Eingabeaufforderung (Windows) die NetWorker-Serverservices:
  • Linux: nsr_shutdown
  • Windows: net stop nsrd
  1. Erstellen Sie eine Kopie der NetWorker-Serverressourcendatenbank (NSRDB):
HINWEIS: Wenn Probleme auftreten, können Sie zu dieser Kopie zurückkehren.
  • Linux: cp -R /nsr/res/nsrdb /nsr/res/nsrdb.beforeclientsecretreset_$(date -I)
  • Windows: Verwenden Sie den Windows-Datei-Explorer, um eine Kopie des Ordners der Ressourcendatenbank zu erstellen. Standardpfad: C:\Programme\EMC NetWorker\nsr\res\nsrdb
  1. Verwenden Sie nsradmin So importieren Sie die Datei clear_client_secret.txt in die NSRDB.
  • Linux: nsradmin -i clear_client_secret.txt -d /nsr/res/nsrdb
  • Windows: nsradmin -i clear_client_secret.txt -d "C:\Program Files\EMC NetWorker\nsr\res\nsrdb"
HINWEIS: Wenn sich die clear_client_secret.txt nicht in demselben Verzeichnis befindet, in dem Sie den Befehl ausführen, müssen Sie den vollständigen Pfad zur Datei angeben. Sie müssen auch den vollständigen Pfad zu Ihrem nsrdb-Ordner angeben.

Beispiel:

azure-nve:~ # nsradmin -i clear_client_secret.txt -d /nsr/res/nsrdb
Current query set
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(186)

Die Zeile "Updated resource" wird für jedes Azure-Abonnement angezeigt, das auf dem NetWorker-Server konfiguriert ist.

  1. Öffnen Sie eine nsradmin Senden Sie eine Aufforderung an die nsrdb und aktualisieren Sie das Clientabonnement für jedes Azure-Abonnement.
  • Linux: nsradmin -d /nsr/res/nsrdb
  • Windows: nsradmin -d "C:\Program Files\EMC NetWorker\nsr\res\nsrdb"

Wenn alle Azure-Abonnements denselben geheimen Azure-Clientschlüssel verwenden, führen Sie die folgenden Schritte aus:

nsradmin> . type: nsr azure subscription
Current query set
nsradmin> show name; client secret
nsradmin> print
               client secret: ;
                        name: Azure;
nsradmin> update cleint secret: REPLACE_WITH_CLIENT_SECRET
               cleint secret: CLIENT_SECRET;
Update? y
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(187)
*Repeat confirmation for each subscription*
nsradmin> q
Wenn mehrere Azure-Abonnements vorhanden sind, die unterschiedliche geheime Clientschlüssel verwenden, führen Sie für jedes Azure-Abonnement die folgenden Schritte aus:
nsradmin> show name
nsradmin> print type: nsr azure subscription
                        name: AZURE_SUBSCRIPTION_NAME;
nsradmin> . type: nsr azure subscription; name: AZURE_SUBSCRIPTION_NAME
Current query set
nsradmin> update client secret: REPLACE_WITH_CLIENT_SECRET
               client secret: CLIENT_SECRET;
Update? y
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(188)
Wiederholen Sie dies für jede Azure-Abonnementressource. Wenn Sie fertig sind, geben Sie Folgendes ein. q oder quit zum Beenden nsradmin.
  1. Starten Sie die NetWorker-Serverservices:
  • Linux: systemctl start networker oder /etc/init.d/networker start
  • Windows: net start nsrd
  1. Überwachen Sie die daemon.raw des Servers auf neue Lockbox-Fehler:
  1. Wenn keine Lockbox-Fehler in Bezug auf die Azure-Abonnements gemeldet werden, überprüfen Sie, ob Sie die Abonnements nach dem Dienststart über die NWUI aktualisieren können.

추가 정보

Wenn das obige Verfahren nicht funktioniert. Die Azure-Abonnements müssen gelöscht und neu erstellt werden.

 

  1. Erstellen Sie eine Kopie der nsrdb (falls noch nicht geschehen). Wenn Sie diese Schritte ausführen, nachdem Sie das obige Verfahren ausgeführt haben, wurde in Lösungsschritt 4 eine Kopie erstellt. Stellen Sie außerdem sicher, dass der Serverschutzjob abgeschlossen wurde. Erfassen Sie Bootstrap-Saveset-Details: mminfo -B
  2. Erfassen Sie die Azure-Abonnementdetails in der Eingabeaufforderung von nsradmin. Dies listet alles außer dem geheimen Clientschlüssel auf. Diese müssen erfasst werden, bevor Sie mit den nächsten Schritten fortfahren. Der Azure-Administrator muss diese Aktionen ausführen. Im Abschnitt Azure Client Secret unten finden Sie jedoch allgemeine Schritte, die erforderlich sind.
nsradmin
print type: nsr azure subscription
HINWEIS: Kopieren Sie die Ausgabe des obigen Befehls in eine Textdatei. Dies sind Voraussetzungen für die erneute Erstellung des Azure-Abonnements.
  1. Löschen der vorhandenen Azure-Abonnementressourcen 
. type: nsr azure subscription
delete
y
HINWEIS: Sie werden aufgefordert, Azure-Abonnements zu löschen (falls mehrere vorhanden sind), bis keines mehr vorhanden ist.
  1. Melden Sie sich bei der NetWorker-Webnutzeroberfläche (NWUI) an und navigieren Sie zu Schutz – Azure-Abonnements>.
  2. Erstellen Sie jedes Azure-Abonnement mithilfe des Namens, des Kommentars, der Mandanten-ID, der Abonnement-ID und der Client-ID neu, die in Schritt 2 gesammelt wurden. Der geheime Clientschlüssel muss vom Kunden oder seinem Azure-Administrator bereitgestellt werden

Geheimer Azure-Client-Schlüssel

Wenn der aktuelle geheime Azure-Clientschlüssel nicht bekannt ist, kann ein neuer in Azure erstellt werden. Nur Azure-Nutzerkonten mit den entsprechenden Berechtigungen können diese Einstellungen und Ressourcen anzeigen. Dies erfordert den Azure-Administrator der Umgebung.

  1. Navigieren Sie im Azure-Portal zu App-Registrierungen (oder suchen Sie).
  2. Unter App-Registrierungen sollten Einträge für jede Client-ID vorhanden sein. Der Namenswert kann unterschiedlich sein, aber die "Client-ID" sollte mit denen übereinstimmen, die in NetWorker verwendet werden:

Azure-App-Registrierungen

  1. Öffnen Sie das App-Registrierungsportal, indem Sie auf den Anzeigenamen klicken.
  2. Erweitern Sie auf dem Ressourcenbildschirm "App-Registrierung" die Dropdown-Liste "Verwalten " und klicken Sie dann auf Zertifikate und Geheimnisse

Optionen für das Management von Anwendungsressourcen

  1. Im Fenster "Zertifikate und Geheimnisse" werden die Geheimnisse angezeigt, die zuvor für die App-Registrierungsressource erstellt wurden:

Zertifikate und Geheimnisse

HINWEIS: Sie können keinen geheimen Clientschlüssel anzeigen, der zuvor erstellt wurde. Sie ist erst unmittelbar nach der Erstellung sichtbar. Wenn der Azure-Administrator den aktuellen geheimen Schlüssel nicht kennt. Es muss eine neue erstellt werden. Verwenden Sie den neuen geheimen Clientschlüssel, wenn Sie das Azure-Abonnement in NetWorker neu erstellen.

해당 제품

NetWorker

제품

NetWorker Family
문서 속성
문서 번호: 000345333
문서 유형: Solution
마지막 수정 시간: 10 11월 2025
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.