Avamar: Unable to Register Any Client after IP Change on Avamar Server

요약: This article explains the client registration failure after Avamar IP change on DP4400, preventing backup and restore operations.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Avamar MC_SYSTEM client registration fails with error "No response to message" after IP address change.
 
The /usr/local/avamar/var/client/avagent.log shows:
root@idpa-avamar:/home/admin/#: /etc/init.d/avagent register idpa-avamar.lab.com /MC_SYSTEM
avagent Info: Stopping Avamar Client Agent (avagent)...
avagent Info: Client Agent stopped.
avagent Info <5008>: Logging to /usr/local/avamar/var/client/avagent.log
avagent Info <5174>: - Reading /usr/local/avamar/var/client/avagent.cmd
avagent Info <5702>: Command Line: /usr/local/avamar/bin/avagent.bin --quiet --init --daemon=false --bindir="/usr/local/avamar/bin" --vardir="/usr/local/avamar/var/client" --sysdir="/usr/local/avamar/etc/client" --logfile="/usr/local/avamar/var/client/avagent.log" --mcsaddr="idpa-avamar.lab.com" --dpndomain="/MC_SYSTEM"
avagent Info <5703>: Parsed Flags: /usr/local/avamar/bin/avagent.bin --debug=true --verbose=1 --x09=3600 --x19=1024 --x30=8192 --x13=524288 --x14=256 --mcsaddr=idpa-avamar.lab.com --mcsport=28001 --acport=28002 --quiet --initialize --service=false --bindir=/usr/local/avamar/bin --vardir=/usr/local/avamar/var/client --sysdir=/usr/local/avamar/etc/client --logfile=/usr/local/avamar/var/client/avagent.log --mcsaddr=idpa-avamar.lab.com --dpndomain=/MC_SYSTEM
avagent Info <42249>: Checking for stale certificate lock
avagent Info <43701>: agent_message::resolve_client_ip ping to MCS idpa-avamar:192.1.68.1.28 using local IP:(none) failed, Program malfunction, Parse bind IP failed for IP: (none)
avagent Info <6601>: Hostnamelist: 127.0.0.2,idpa-avamar.lab.com,idpa-avamar,192.1.68.1.28,fe80::250:56ff:fe9d:6d8d
avagent Info <6609>: UN-Registering with the MCS (idpa-avamar)
avagent Error <5061>: No response to message
avagent Error <6210>: Unable to register '/MC_SYSTEM/idpa-avamar' with MCS at idpa-avamar:28001
avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />)
avagent Info <43701>: agent_message::resolve_client_ip ping to MCS idpa-avamar.lab.com:192.1.68.1.28 using local IP:(none) failed, Program malfunction, Parse bind IP failed for IP: (none)
avagent Info <18918>: Registration: Processing secure registration with the MCS.
avagent Info <18921>: Registration: Requesting root CA from the MCS.
avagent Error <5061>: No response to message
avagent Info <18936>: Unable to securely register with the MCS (idpa-avamar.lab.com)
avagent Error <5036>: Unable to register CR_ERROR
2025/12/11-19:58:34.50852 [avagent] Debug output redirect end
2025/12/11-19:58:34.50897 [avagent] Thread finished avagent
avagent Info: Client activation error.
avagent Info <5008>: Logging to /usr/local/avamar/var/client/avagent.log
avagent Info <5174>: - Reading /usr/local/avamar/var/client/avagent.cmd
avagent Info <5417>: daemonized as process id 5151
avagent Info: Client Agent started.
root@idpa-avamar:/home/admin/#:

원인

Incorrect login_server_port value in /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml

Affected Avamar server mcserver.xml:

admin@idpa-avamar:~/>: grep login_server_port /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
            <entry key="login_server_port" value="28001" />
admin@idpa-avamar:~/>:

Lab environment:

admin@avamar-srv10:~/>: grep login_server_port /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml
            <entry key="login_server_port" value="7779"/>
admin@avamar-srv10:~/>:

해결

1. Log in to the Avamar server as admin.
2. Edit the /usr/local/avamar/var/mc/server_data/prefs/mcserver.xml using vi or vim.
3. Replace the value on login_server_port to the default port which is 7779.

<entry key="login_server_port" value="7779"/>

4. Restart the Management Console Service (MCS)

mcserver.sh --restart

5. Register the MC_SYSTEM client again and confirm that the registration completes successfully.
6. Resume the other services.

dpnctl start

해당 제품

Avamar
문서 속성
문서 번호: 000404211
문서 유형: Solution
마지막 수정 시간: 16 12월 2025
버전:  1
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.