Avamar : Problème Tomcat : Client Manager n’est pas accessible. Les modifications apportées au fichier server.xml ne sont pas persistantes
Resumo: Les modifications sont apportées au fichier server.xml, mais le redémarrage du service tomcat rétablit les modifications. Cet article de la base de connaissances explique également où tomcat n’est pas accessible, car le port 8509 n’écoute pas sur la version 127.0.0.1. ...
Este artigo aplica-se a
Este artigo não se aplica a
Este artigo não está vinculado a nenhum produto específico.
Nem todas as versões do produto estão identificadas neste artigo.
Sintomas
Tomcat était opérationnel, mais la page Web AAM (Client Manager) n’est pas accessible :
/var/log/apache2/mod_jk.log affiche une erreur lors de la connexion sur le port 8509.
Curl vers le port 8509 vers localhost affichait une connexion refusée.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_open_socket::jk_connect.c (758): connect to 127.0.0.1:8509 failed (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_connect_to_endpoint::jk_ajp_common.c (1019): Failed opening socket to (127.0.0.1:8509) (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_send_request::jk_ajp_common.c (1663): (cas) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] ajp_service::jk_ajp_common.c (2673): (cas) sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [error] ajp_service::jk_ajp_common.c (2693): (cas) connecting to tomcat failed.
[Tue Aug 16 17:57:01 2022] [26136:139641497630912] [info] jk_handler::mod_jk.c (2837): Service error=-3 for worker=cas
Curl vers le port 8509 vers localhost affichait une connexion refusée.
root@testlab:/usr/local/avamar-tomcat/conf/#: curl -kv https://127.0.0.1:8509
* Rebuilt URL to: https://127.0.0.1:8509/
* Trying 127.0.0.1...
* TCP_NODELAY set
* connect to 127.0.0.1 port 8509 failed: Connection refused
* Failed to connect to 127.0.0.1 port 8509: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 8509: Connection refused
Causa
Le port 8509 n’écoute pas l’hôte local.
Resolução
1. Connectez-vous au serveur Avamar en tant qu’utilisateur administrateur et accédez à l’utilisateur root :
2. Sauvegardez le fichier de configuration server.xml existant :
3. Modifiez /usr/local/avamar-tomcat/conf/server.xml et /usr/local/avamar/etc/server.xml, ajoutez la ligne mise en surbrillance ci-dessous :
4. Enregistrez le fichier, puis fermez-le.
5. Redémarrez tomcat et Apache :
2. Sauvegardez le fichier de configuration server.xml existant :
cp -p /usr/local/avamar-tomcat/conf/server.xml /usr/local/avamar-tomcat/conf/server.xml-orig
cp -p /usr/local/avamar/etc/server.xml /usr/local/avamar/etc/server.xml-orig
3. Modifiez /usr/local/avamar-tomcat/conf/server.xml et /usr/local/avamar/etc/server.xml, ajoutez la ligne mise en surbrillance ci-dessous :
5. Redémarrez tomcat et Apache :
emwebapp.sh --restart
service apache2 restart
Propriedades do artigo
Número do artigo: 000203109
Tipo de artigo: Solution
Último modificado: 14 jul. 2023
Versão: 2
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.