Data Domain: Resolving the "Known" Disk State

Summary: This article explains why a disk may appear in a "known" state on a Data Domain system and provides steps to diagnose and resolve the condition.

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

 
  • The system indicates that one or more disk drives are in a 'known' state
    • As seen in the DD-CLI command: # disk show state

APPLIES TO

  • All Data Domain systems
  • All Software Releases

Cause

A disk in Known state indicates that:

  • RAID identifies and recognizes the drive, but the Disk Group is not fully reassembled.

This state can occur due to:

  • Missing two or more drives in the disk group (enclosure).
  • RAID reassembly failure caused by excessive disk or I/O errors
  • A faulty disk causing path errors on both primary and secondary SAS paths
  • Adding an enclosure "live" while the system is online
  • Shelves remaining uncabled for extended periods (> 5 minutes)
  • Faulty or loose SAS cable connections

Resolution

      1. Verify the Disk state using the DD-CLI command: # disk show state
      2. Verify that all cables are connected and thumbscrews are fastened securely to attached storage..
      3. Verify if the disk drives are encountering CRC errors or have reallocated sectors: # disk show reliability-data
      4. A failing disk drive can cause other disks to report as known.
      5. If multiple faulty disks are reported, the RAID group may need to be manually reassembled.
        • Contact your Support Provider to perform the RAID reassembly procedure (this does not require a reboot).
        • A Reboot of the DD unit attempts to reassemble the 'Known' disks and affected disk group.
          • Recommendation: For single disks a reboot is OK, for multiple disks, consult Dell Tech Support for assistance.
      6. Verify the Disk state (#disk show state) to ensure the disks show In Use or Spare.
        • If disks are still reporting as known, gather a Support Bundle (SUB) and Create a service request for more in-depth troubleshooting.

      Additional Information

      Produse afectate

      Data Domain

      Produse

      Data Domain
      Proprietăți articol
      Article Number: 000042904
      Article Type: Solution
      Ultima modificare: 20 ian. 2026
      Version:  6
      Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
      Servicii de asistență
      Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.