Data Domain: Festplatte unbekannt
Summary: In diesem Artikel wird erläutert, warum eine Festplatte in einem Data Domain-System als "Unknown" angezeigt werden kann, und es werden Schritte zur Identifizierung und Behebung des Problems aufgeführt. ...
Symptoms
Eine Festplatte zeigt in DD-CLI, DDSM oder DDMC den Status "Unknown" an.
Das Problem betrifft eines der folgenden Szenarien:
- Eine einzelne Festplatte im Controller (Haupteinheit) oder angeschlossenen Speicher
- Alle Festplatten in einem neu hinzugefügten Gehäuse
- Eine Festplatte, die kürzlich nach einem Ausfall ausgetauscht wurde
Cause
Ein Laufwerk wird möglicherweise aus einem der folgenden Gründe als "Unbekannt" gemeldet:
- Das System hat eine neu eingesetzte Festplatte noch nicht erkannt.
- Ein Laufwerk ist unzuverlässig oder fehlerhaft und meldet einen unbekannten Status.
- Ein neu hinzugefügtes Gehäuse wurde nicht in die RAID-Konfiguration integriert.
- Ein Ersatzlaufwerk wurde nicht initialisiert oder in einen aktiven Zustand versetzt.
Resolution
Führen Sie je nach Szenario die folgenden Schritte aus:
-
Prüfen Sie Ihr Data Domain-Modell
Wichtig: Die
disk unfailwird auf Systemen mit Storage-Poolarchitektur (z. B. DD6400) nicht unterstützt. Das Ausführen dieses Befehls auf diesen Modellen führt zu einem Fehler.-
Identifizieren Sie Ihr Systemmodell:
system show modelno -
Verwenden Sie das richtige Verfahren:
DD6400 (Storage-Poolarchitektur):
- Wählen Sie die
storage addverwenden. - Siehe: Data Domain DD6400: Hinzufügen einer Ersatzfestplatte auf DD6400
Alle anderen Data Domain-Modelle (herkömmliche DD-RAID-Architektur):
- Fahren Sie mit den folgenden Schritten fort (
disk rescan,disk unfail).
- Wählen Sie die
-
-
Überprüfen des Festplattenstatus
- Wählen Sie die
disk show stateBefehl zum Ermitteln des Festplattenstatus. Weitere Informationen finden Sie unter Data Domain: Beschreibungen des Festplattenstatus
- Wählen Sie die
-
Eine einzelne Festplatte meldet "Unbekannt" (und ist KEINE neue Ersatzfestplatte)
- Überprüfen der aktiven Systemwarnmeldungen (
alerts show current) und den Festplattenstatus (disk show state). Wenn das Laufwerk als fehlerhaft gemeldet wird und sich in einem unbekannten Zustand befindet, ersetzen Sie es. - Wenn es sich bei der " unbekannten" Festplatte um eine neu eingesetzte (Ersatz-)Festplatte handelt, fahren Sie mit Schritt 5 fort.
- Überprüfen der aktiven Systemwarnmeldungen (
-
Alle Festplatten in einem neuen Gehäuse sind als "Unbekannt" gekennzeichnet.
- Dies ist das erwartete Verhalten für einen neu hinzugefügten Einschub.
- Befolgen Sie das entsprechende Einschub-Hardwarehandbuch , damit die "unbekannten" Festplatten zur Storage-Kapazität hinzugefügt werden.
- Übersicht über die erforderlichen Schritte zum Hinzufügen eines Einschubs:
- Lizenzierung anwenden
- Hinzufügen von Speicher zum richtigen Tier (aktiv oder Cloud)
- Erweitern des Dateisystems
- Übersicht über die erforderlichen Schritte zum Hinzufügen eines Einschubs:
- Befolgen Sie das entsprechende Einschub-Hardwarehandbuch , damit die "unbekannten" Festplatten zur Storage-Kapazität hinzugefügt werden.
- Dies ist das erwartete Verhalten für einen neu hinzugefügten Einschub.
-
Eine einzelne Festplatte meldet nach dem Austausch "Unbekannt"
- Versuchen Sie, die Laufwerke erneut einzuscannen. Führen Sie in DD-CLI (ssh) den folgenden Befehl aus:
# disk rescan - Überprüfen Sie den Status des Laufwerks über DD-CLI.
# disk show state- Wenn die Festplatte in Gebrauch ist und die Warnmeldung nicht gelöscht wurde, löschen Sie die Warnmeldung manuell über DD-CLI
# alerts clear alert-id <alert-id> - Wenn das Laufwerk weiterhin "unbekannt" ist, führen Sie den Befehl #
disk unfail <encl.disc> commandSo versetzen Sie das Laufwerk in einen Spare-Zustand.
- Wenn die Festplatte in Gebrauch ist und die Warnmeldung nicht gelöscht wurde, löschen Sie die Warnmeldung manuell über DD-CLI
- Versuchen Sie, die Laufwerke erneut einzuscannen. Führen Sie in DD-CLI (ssh) den folgenden Befehl aus:
-
Zusätzliche Unterstützung
erforderlichWenden Sie sich an den von Ihnen beauftragten Support-Anbieter und stellen Sie einen Service-Request, wenn das Problem weiterhin besteht.
Additional Information
Best Practice: Zwei Minuten Wartezeit während des Festplattentauschs
- Wenn Sie ein Festplattenlaufwerk physisch austauschen, warten Sie nach dem Entfernen der fehlerhaften Festplatte mindestens zwei Minuten, bevor Sie die neue Festplatte einsetzen.
- Auf diese Weise kann die Controller-Firmware die Registrierung des alten Laufwerks ordnungsgemäß aufheben, wodurch die Wahrscheinlichkeit eines Hotplug-Problems, bei dem das neue Laufwerk nicht richtig erkannt wird (als "unbekannt" angezeigt) erheblich reduziert wird.
Empfohlene Reihenfolge:
- Entfernen Sie die fehlerhafte Festplatte aus dem Steckplatz.
- Warten Sie zwei Minuten.
- Legen Sie die neue Ersatzfestplatte ein.