VNX: Помилка VC CAVA: 3: 32: Сервер 'x.x.x.x' видав помилку 'FAIL' при перевірці файлу
Summary: Помилки в журналах переміщення даних свідчать про те, що служба VC не відсканувала файл
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
Під час перевірки на вірус у журналах з'являється помилка, що VC-сервіс не перевірив її:
2016-03-29 11:38:44: VC: 3: 32: Сервер 'x.x.x.x' видав помилку 'FAIL' при перевірці файлу '\root_vdm_id\mount_path\filename.ext'
Cause
Повідомлення 'FAIL' виникає, коли відкривається запит на сканування (VC-сервіс на дата-мувері надсилає запит серверам CAVA), і коли CAVA-сервер намагається його відкрити, файл не знаходиться. Це означає, що файл було видалено до того, як його можна було відсканувати. Є кілька сценаріїв, де це може статися:
- Один із способів — якщо файл був файлом cookie, тимчасовим або файлом блокування. Microsoft Office, наприклад, створює тимчасові файли у форматі ~$<original_filename.xxxx>. Ці файли зазвичай зникають, коли файл збережено або закрито, і якщо це відбувається швидко, файл може зникнути до того, як його відсканують, що призводить до повідомлення FAIL у журналі переміщення даних. Імена файлів, які не проходять сканування, зазвичай вказують на це як джерело проблеми.
- Ще один спосіб, яким це може статися — якщо файл має особливу «розпозицію». У SMB та SMB2 користувач може встановити диспозицію «видалити при закритті» при відкритті файлу. Якщо файл, який направляється для сканування, відкриває інший користувач із цим налаштуванням, файл видаляється до того, як його можна буде відсканувати, що призводить до повідомлення FAIL у журналах переміщення даних. Цю опцію можна побачити у трасуванні пакетів, дивлячись на виклики SMB 'Create' або 'SetInfo', але вона буде встановлена користувачем, який виконує видалення, а ймовірно не серверами CAVA. Це може ускладнити роботу, оскільки потрібно контролювати звичайний трафік (не лише AV-сервер), щоб визначити, хто встановлює прапорець.
Resolution
Найкраще рішення — зупинити видалення файлу (зовнішніми користувачами, які його видаляють). Це може означати вимкнення використання тимчасових файлів в офісі або зберігання інших тимчасових файлів чи cookie у локальній директорії замість спільної. Якщо це неможливо, тоді змініть viruschecker.conf, щоб виключити такі типи файлів із перевірки, змінивши рядок 'excl' на виключення ~$*.* (для офісних файлів), *.tmp або будь-якого іншого розширення, яке може спричиняти ці помилки.
viruschecker.conf:CIFSserver=CIFS server on data mover
>addr=<configured CAVA servers>
excl=~$*.*:*.accdb:*.laccdb:*.ldb:*.mdb:*.pst:*.tmp:????????
<
маски=*.*
вимкнення=перевірка на вірус
viruschecker.conf:CIFSserver=CIFS server on data mover
>addr=<configured CAVA servers>
excl=~$*.*:*.accdb:*.laccdb:*.ldb:*.mdb:*.pst:*.tmp:????????
<
маски=*.*
вимкнення=перевірка на вірус
Additional Information
Додаткові ресурси:
функція https://wiki.wireshark.org/SMB2/SMB2_FILE_DISPOSITION_INFO
(SMB2_FILE_DISPOSITION_INFO адреси «видалити при закритті»)
Produse afectate
VNX1 SeriesProduse
Celerra, VNX1 Series, VNX2 SeriesProprietăți articol
Article Number: 000052379
Article Type: Solution
Ultima modificare: 25 mai 2026
Version: 4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.