PowerEdge: Windows Server SYSVOL paylaşımı tüm etki alanı denetleyicilerinde yok

Summary: SYSVOL paylaşımı, Active Directory (AD) etki alanındaki her etki alanı denetleyicisinde (DC) yoksa AD yönetim konsolları aşağıdaki gibi bir hata verebilir: "Etki alanı için bir Active Directory etki alanı denetleyicisi (AD DC) iletişim kurulamadı." SYSVOL verilerini çoğaltmak için Dağıtılmış Dosya Sistemi Çoğaltması (DFSR) kullanılıyorsa sorunun çözülmesi zor görünüyor. ADSI Edit konsolu olmadan DFSR'nin yetkili senkronizasyonu yapılamaz. Neyse ki bu sorun, DC'deki kayıt defterini SYSVOL'ün yetkili kopyasıyla değiştirerek çözülebilir. Ardından diğer DC'lerde farklı bir kayıt defteri değişikliği gerçekleştirilir. ...

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

Not: Bu makale yalnızca SYSVOL verilerini çoğaltmak için Dağıtılmış Dosya Sistemi Çoğaltması (DFSR) kullanılıyorsa geçerlidir. File Replication Service (FRS) kullanılıyorsa burada verilen çözüm işe yaramaz.

Etki alanındaki hiçbir etki alanı denetleyicisi (DC) SYSVOL paylaşımına sahip değildir.

Bir makineyi etki alanına ekleme girişimi "Etki alanı <etki alanı> için bir Active Directory etki alanı denetleyicisine (AD DC) bağlanamadı" hatası veriyor.

AD Kullanıcıları ve Bilgisayarları gibi Active Directory yönetim konsolları aynı hatayı bildirebilir.

Grup İlkesi Yönetim Konsolu, Grup İlkesi nesnelerinin (GPO'lar) eksik olduğunu belirten hatalar bildirir.

Tüm DC'lerin DFS Çoğaltma olay günlükleri, aşağıdaki açıklamayla birlikte 4612 hatasını içerir:

The DFS Replication service initialized SYSVOL at local path C:\Windows\SYSVOL\domain and is waiting to perform initial replication. The replicated folder will remain in the initial synchronization state until it has replicated with its partner [server]. If the server was in the process of being promoted to a domain controller, the domain controller will not advertise and function as a domain controller until this issue is resolved. [The rest of the event description has been omitted here.]


Yukarıdaki hata açıklamasında başvurulan sunucu, rütbesi düşürülmüş eski bir DC'dir.

Cause

Bu sorun en yaygın olarak, yeni DC'ler bir etki alanında yükseltildiğinde ve SYSVOL çoğaltmasının işlevsel olup olmadığı doğrulanmadan eski DC'lerin rütbesi düşürüldüğünde oluşur. Bu durumda, SYSVOL verileri kullanımda olan ve etki alanında bulunmayan herhangi bir DC'ye başarıyla çoğaltılamaz.

Resolution

Not: Aşağıda verilen adımlar, yalnızca etki alanındaki tüm etki alanı denetleyicilerinde SYSVOL paylaşımının bulunmadığı durumlarda uygulanmalıdır. En az bir DC'nin SYSVOL paylaşımı varsa AD konsolları bu DC'ye yönlendirildiğinde işlevsel olmalıdır. Bunun yerine normal senkronizasyon prosedürü (yetkili veya yetkili olmayan) kullanılmalıdır. Bu adımlar temel olarak, ADSI Düzenlemesi kullanmadan DFS ile çoğaltılan SYSVOL verilerinin yetkili senkronizasyonunu zorlamanın bir yoludur.


Öncelikle, SYSVOL verilerinin en güncel kopyasını bulun. Bu, %systemroot%\SYSVOL\domain\Policies konumunda bulunan Grup İlkesi Şablonu dosyalarının en son sürümleri için geçerli ve eski etki alanı denetleyicilerini arayabilir. Böyle bir yedekleme mevcutsa bu verileri, rütbesi düşürülmüş bir DC'nin yakın tarihli bir yedeğinden geri yüklemek gerekebilir. (Bu amaç için oluşturulan geçici bir konuma geri yükleyin.)


Tüm DC'lerde DFS Kopya hizmetini durdurun. Ardından, yetkili SYSVOL kaynağı olacak DC'yi seçin. (Bu durumda, hangi DC'nin seçildiği önemli değildir.) SYSVOL verilerinden Politikalar ve komut dosyaları klasörlerini %systemroot%\SYSVOL\domain yetkili DC'de.
 

Not: SYSVOL verilerinin bir kopyası bulunamazsa iki varsayılan GPO'yu sıfırdan yeniden oluşturmak için DCGPOFIXBu köprü bağlantı sizi Dell Technologies dışındaki bir web sitesine yönlendirir. komutu kullanılabilir. Diğer tüm GPO'lar ve SYSVOL hiyerarşisinde depolanan diğer veriler manuel olarak yeniden oluşturulmalıdır. Bu komut son çare olarak kullanılmalıdır.


Kayıt Defteri Düzenleyicisi'ni başlatın (regedit) ve şuraya gidin: HKLM\System\CurrentControlSet\Services\DFSR\Parameters. Sysvols alt anahtarına sağ tıklayın ve Export öğesini seçin. Dosyayı erişilebilir bir konuma kaydedin. (Bu dosyaya büyük olasılıkla ihtiyaç duyulmaz, ancak bir şeyler ters giderse bu kayıt defteri anahtarının yedeği görevi görür.) Kayıt Defteri Düzenleyicisi'ni kapatın.


Bu DC'deki Not Defteri'ne aşağıdaki metni kopyalayın:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DFSR\Parameters\SysVols\Promoting SysVols]
"Sysvol Information is Committed"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DFSR\Parameters\SysVols\Promoting SysVols\DOMAINNAME]
"Is Primary"=dword:00000001
"Command"="DcPromo"
"Parent Computer"=""
"Replicated Folder Name"="DOMAINNAME"
"Replicated Folder Root"="C:\\Windows\\SYSVOL\\Domain"
"Replicated Folder Root Set"="C:\\Windows\\SYSVOL\\sysvol\\DOMAINNAME"
"Replicated Folder Stage"="C:\\Windows\\SYSVOL\\staging areas\\DOMAINNAME"
"Replication Group Name"="DOMAINNAME"
"Replication Group Type"="Domain"


Not Defteri'ndeki Düzen menüsünden Değiştir... öğesini seçin ve tüm DOMAINNAME örneklerini AD etki alanının adıyla değiştirin (örneğin, ad.mydomain.com). Etki alanı adının doğru olduğundan emin olun. Gerekirse dosya yollarını, sunucudaki SYSVOL klasörünün konumunu yansıtacak şekilde ayarlayın. Dosyayı şu şekilde kaydedin: Promoting_Sysvols.reg. Dosya adına .txt uzantısı eklenmemesi için Kayıt türü: açılır listesinden Tüm Dosyalar (*.*) öğesini seçtiğinizden emin olun.


Sağ tıklayın Promoting_Sysvols.reg dosyasını açın ve Birleştir'i seçin. İstendiğinde Evet öğesine tıklayın. Dosyadaki veriler DC'nin kayıt defteriyle başarılı bir şekilde birleştirilmelidir. Tamam'a tıklayın.


DFS Kopya hizmetini yalnızca bu DC'de başlatın. Olay Görüntüleyicisi'ni başlatın ve olay 4602 görünene kadar DFS Çoğaltma olay günlüğünü yenileyin. SYSVOL Bu DC'deki çoğaltma artık işlevseldir ve net share Komut şimdi gösterilmelidir SYSVOL ve NETLOGON Hisse.


Etki alanındaki diğer tüm DC'lerde aşağıdakileri yapın:

  1. Kayıt Defteri Düzenleyicisi'ni başlatın ve şuraya gidin: HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/DFSR/Parameters/SysVols/Seeding SysVols/[Domain name].
  2. Bu anahtarın içindeki Ana Bilgisayar ayarını bulun ve ayarını yetkili DC'nin DNS adı olarak ayarlayın.
  3. Kayıt Defteri Düzenleyicisi'ni kapatın ve DFS Kopya hizmetini başlatın.
  4. Olay Görüntüleyicisi'ni başlatın ve ilk çoğaltmanın tamamlandığını gösteren olay 4604 görünene kadar DFS Çoğaltma olay günlüğünü yenileyin. SYSVOL başlatıldı.
  5. Sürücüyü yüklemek için ilgili düğümde net share varlığını doğrulamak için SYSVOL ve NETLOGON Hisse.

Produse afectate

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525 , OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t ...
Proprietăți articol
Article Number: 000198564
Article Type: Solution
Ultima modificare: 10 dec. 2025
Version:  7
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.