Servizi di backup APEX | Il backup del registro delle transazioni SQL ha esito positivo con errori

Summary: Il backup del registro SQL ha esito positivo con errori quando il backup dei file di registro di alcuni DB è stato ignorato. La catena di log dei DB ignorati dal backup appare interrotta. ...

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

Tracciabilità

<Line 702: [2018-06-17 07:38:08,638] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Could not backup log files for 12 DBs, WH-RPT02\ProjectQuoting, WH-RPT02\LFAudit_3EDocuments, WH-RPT02\3EDocuments, WH-RPT02\SSISDB, WH-RPT02\3EWorkFlow, WH-RPT02\ReportServer, WH-RPT02\Insite, WH-RPT02\ProjectQuoting_Test, WH-RPT02\WebTracksSQL, WH-RPT02\Helpdesk, WH-RPT02\ReportServerTempDB, WH-RPT02\InforDB 

Line 552: [2018-06-17 07:37:57,923] [INFO] Log chain broken: WH-RPT02:Helpdesk 
Line 559: [2018-06-17 07:37:58,065] [INFO] Log chain broken: WH-RPT02:ProjectQuoting_Test 
Line 563: [2018-06-17 07:37:58,171] [INFO] Log chain broken: WH-RPT02:3EWorkFlow 
Line 566: [2018-06-17 07:37:58,272] [INFO] Log chain broken: WH-RPT02:SSISDB 
Line 569: [2018-06-17 07:37:58,404] [INFO] Log chain broken: WH-RPT02:Insite 
Line 572: [2018-06-17 07:37:58,477] [INFO] Log chain broken: WH-RPT02:InforDB 
Line 574: [2018-06-17 07:37:58,584] [INFO] Log chain broken: WH-RPT02:ReportServerTempDB 
Line 579: [2018-06-17 07:37:58,713] [INFO] Log chain broken: WH-RPT02:ReportServer

Cause

Un backup di log SQL nativo o di terze parti in esecuzione sul server potrebbe aver causato l'interruzione della catena di log.

Come verificare il backup nativo dei log SQL

È possibile verificare se sono stati eseguiti backup nativi dal report "Eventi di backup e ripristino". Questo report esegue calcoli per mostrare i dati in un formato più leggibile.

Avviare SQL Server Management Studio (SSMS)

  • Selezionare il database
  • Cliccare con il pulsante destro del mouse e selezionare Report
  • Report standard:> eventi di backup e ripristino
  • Cliccare con il pulsante destro del mouse sul report ed esportarlo in formato CSV.



image.png

  • Espandere la sezione "Operazioni di backup riuscite"
  • La colonna "Tipo di dispositivo" mostra il percorso del file di backup fisico. Se è un disco, significa che è stato eseguito un backup nativo.
  • È inoltre possibile verificare il modello di ripristino e il nome utente da questo report.
 

Resolution

 

  1. Disabilitare o eliminare i backup dei registri SQL di terze parti per l'istanza SQL interessata (backup set), inclusi i backup nativi SQL, e avviare un backup manuale da Phoenix Management Console. I successivi backup dei log delle transazioni devono essere completati correttamente. Eseguire backup nativi di sola copia da SQL Server se non è possibile disabilitare i backup nativi o di terze parti.  
  2. Se il passaggio precedente non è possibile, il software di protezione degli endpoint/backup di terze parti/antivirus dispone di un'opzione per disabilitare/escludere il writer VSS specifico. Pertanto, disabilitare/escludere SqlServerWriter dalle impostazioni del software. Il successivo backup SQL FULL/Diff risolve il problema.
  3. Un'altra soluzione consiste nell'avere una policy in modo tale che il backup completo di Phoenix SQL/DIFF venga sempre attivato dopo i backup SQL di terze parti/nativi (piano di manutenzione)/protezione degli endpoint.
  4. Se per qualche motivo è necessario modificare il modello di ripristino di un database, creare un altro backup set per questo SQL Server. Dopo le modifiche, solo i backup per questo backup set avranno esito negativo e gli altri backup non saranno interessati. 
 

Nota: Prima di creare un nuovo backup set per questo database, deselezionarlo dal backup set corrente. 

Produse afectate

APEX Cloud Services, PowerProtect Backup Services
Proprietăți articol
Article Number: 000207849
Article Type: Solution
Ultima modificare: 18 feb. 2026
Version:  2
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.