Openshift: Chyba po kontrole upgradu OCP, když uzel není připraven nebo je zakázáno plánování
Summary: Chyba po upgradu OCP, když uzel není připraven nebo je zakázáno plánování z důvodu virtuálního počítače nakonfigurovaného se svazkem úložiště ReadWriteOnce (RWO), který nelze migrovat za provozu. ...
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
Během procesu aktualizace OCP po kontrole se může zobrazit chybová zpráva "Failed to run post check for OCP cluster. Uzel není připraven nebo je zakázáno plánování."
Cause
Jeden nebo více virtuálních počítačů nakonfigurovaných se svazkem úložiště ReadWriteOnce (RWO), který nelze migrovat za provozu na uzlu zasílání zpráv o chybách.
Další informace o svazcích úložiště pro disky virtuálních počítačů naleznete v dokumentu Openshift.
Resolution
1. Změňte nastavení PV virtuálního počítače.
2. Vyhledejte uzly, jejichž stav je "Ready,SchedulingDisabled".
3. Vypusťte uzel a odeberte z něj spuštěné lusky.
4. Nastavte režim ladění a restartujte uzel.
5. Jakmile je uzel připravený po restartování, označte jej jako plánovatelný.
6. Ověřte, zda je uzel úspěšně označen jako plánovatelný.
- 1.1zastavte instanci virtuálního počítače před změnou nastavení PV.
- 1.2 Klikněte na virtuální počítač a přepněte na kartu YAML
- 1.3 Změna accessModes z "ReadWriteOnce" na "ReadWriteMany"
- 1.4 Pokud PV nelze nastavit na ReadWriteMany (virtuální počítač nemůže spustit use ReadWriteMany), nastavte evictionStrategy z LiveMigrate na None
Poznámka: Proveďte kroky 1.3 nebo 1.4, které se vztahují na vaše prostředí, nemusíte provádět oba kroky.
- 1.5 Klikněte na tlačítko Save a restartujte virtuální počítač.
2. Vyhledejte uzly, jejichž stav je "Ready,SchedulingDisabled".
$ oc get nodeNapříklad:
3. Vypusťte uzel a odeberte z něj spuštěné lusky.
$ oc adm <node name> --ignore-daemonsets --delete-emptydir-data --forceNapříklad: oc adm drain c3-esx01.racka01.local --ignore-daemonsets --delete-emptydir-data --force
4. Nastavte režim ladění a restartujte uzel.
$ oc debug node/<node name> $ sh-4.4# chroot /host $ sh-4.4# systemctl reboot
5. Jakmile je uzel připravený po restartování, označte jej jako plánovatelný.
$ oc adm uncordon <node name>
6. Ověřte, zda je uzel úspěšně označen jako plánovatelný.
$ oc get node
Produse afectate
APEX Cloud Platform for Red Hat OpenShiftProprietăți articol
Article Number: 000216593
Article Type: Solution
Ultima modificare: 18 sept. 2026
Version: 4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.