Openshift: ノードの準備ができていない、またはスケジュールが無効になっていることによるOCPアップグレードの事後チェック エラー
Summary: ライブ移行できないReadWriteOnce (RWO)ストレージ ボリュームで構成されたVMが原因で、ノードの準備ができていない、またはスケジュールが無効になっている場合のOCPアップグレードの事後チェック エラー。
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
OCPアップグレードの事後チェック プロセス中に、「OCPクラスターの事後チェックの実行に失敗しました。Node is not ready or scheduling disabled.」
Cause
エラー報告ノードでライブ マイグレーションできないReadWriteOnce(RWO)ストレージ ボリュームで構成された1つ以上のVM。
仮想マシン ディスクのストレージ ボリュームの詳細については、以下のOpenShiftドキュメントを確認してください。
Resolution
1.VM PV設定を変更します。
2.ステータスが「Ready,SchedulingDisabled」のノードを見つけます。
3.ノードをドレインして、実行中のポッドをノードから削除します。
4。デバッグ モードを設定し、ノードを再起動します。
5.再起動後にノードの準備が整ったら、スケジュール可能としてマークします。
6.ノードがスケジュール可能として正常にマークされていることを確認します。
- 1.1PV設定を変更する前に、VMインスタンスを停止します。
- 1.2 VMをクリックし、[YAML]タブに切り替えます
- 1.3 accessModesを 「ReadWriteOnce」から「ReadWriteMany」に変更する
- 1.4 PVをReadWriteManyに設定できない(VMがReadWriteManyの使用を開始できない)場合は、LiveMigrateのevictionStrategyをNoneに設定します
注:環境に適用される手順1.3または1.4のいずれかを実行してください。両方の手順を実行する必要はありません。
- 1.5 [Save]をクリックして、VMを再起動します。
2.ステータスが「Ready,SchedulingDisabled」のノードを見つけます。
$ oc get node例:
3.ノードをドレインして、実行中のポッドをノードから削除します。
$ oc adm <node name> --ignore-daemonsets --delete-emptydir-data --force例:oc adm drain c3-esx01.racka01.local --ignore-daemonsets --delete-emptydir-data --force
4。デバッグ モードを設定し、ノードを再起動します。
$ oc debug node/<node name> $ sh-4.4# chroot /host $ sh-4.4# systemctl reboot
5.再起動後にノードの準備が整ったら、スケジュール可能としてマークします。
$ oc adm uncordon <node name>
6.ノードがスケジュール可能として正常にマークされていることを確認します。
$ oc get node
Produse afectate
APEX Cloud Platform for Red Hat OpenShiftProprietăți articol
Article Number: 000216593
Article Type: Solution
Ultima modificare: 18 sept. 2026
Version: 4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.