OpenShift-Virtualisierung: Der VM-Snapshot konnte nicht von der OpenShift-Virtualisierungs-Benutzeroberfläche erstellt werden.

Summary: Das Erstellen eines VM-Snapshots über die OpenShift-Virtualisierungs-Benutzeroberfläche schlägt fehl, wenn I/O auf der VM im OCP-Cluster ausgeführt wird.

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

Das Erstellen eines VM-Snapshots über die OpenShift-Virtualisierungs-Benutzeroberfläche ist fehlgeschlagen.
image.png

Beim Überprüfen der Protokolle des virt-handler-Pods (openshift-cnv-Namespace) werden Fehler wie die folgenden angezeigt:
2023-08-14T02:23:33.722372232Z {"component":"virt-handler","kind":"","level":"error","msg":"Fehler beim Einfrieren von VMI","name":"rhel9-vm-http-block",
"namespace":"rhel-vm","pos":"lifecycle.go:124","reason":"Serverfehler.
Befehl Einfrieren fehlgeschlagen: \"LibvirtError(Code=1, Domain=10, Message='interner Fehler: QEMU-Agent-Befehl 'guest-fsfreeze-freeze' kann nicht ausgeführt werden:
Öffnen von /zoner/sda: Permission denied')\"","timestamp":"2023-08-14T02:23:33.722321Z","uid":"c6894dc7-f29c-43e7-9817-3b12643040d1"}

Cause

Beim Erstellen einer VM über OpenShift Virtualization wird der Bereitstellungspunkt von der erstellten LUN nicht als vertrauenswürdig gekennzeichnet. Während des VM-Snapshot-Prozesses kann der QEMU-Agent den Einhängepunkt nicht öffnen (in diesem Wissensdatenbank-Artikel ist der Einhängepunkt /zoner/sda) und erhält eine verweigerte Berechtigung, während er versucht, fsfreeze auszuführen.

Resolution

Bei den folgenden Lösungsschritten wird "/zoner/sda" als Einhängepunkt angenommen.

Verwenden Sie den Befehl "df -h" und überprüfen Sie in Ihren Fehlerprotokollen, ob der tatsächliche Bereitstellungspunkt für die Fehlermeldung Ihrer VM korrekt ist.


1. Bestätigen Sie, dass der SELinux-Kontext des Einhängepunkts "unlabeled_t" anzeigt, indem Sie den folgenden Befehl ausführen:

# ls -lZd /zoner/sda/


2. Wenn "unlabeled_t" angezeigt wird, gibt es zwei Möglichkeiten, das Problem zu beheben.

  • Option 1: So aktivieren Sie den QEMU-Agenten, nicht etikettierte Dateien zu lesen.
# setsebool -P virt_qemu_ga_read_nonsecurity_files 1

 

  • Option 2: So bezeichnen Sie den Bereitstellungspunkt.
# restorecon -v /zoner/sda/

 

Produse afectate

APEX Cloud Platform for Red Hat OpenShift
Proprietăți articol
Article Number: 000217270
Article Type: Solution
Ultima modificare: 18 sept. 2026
Version:  4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.