OpenShift Virtualization : Échec de la création d’un snapshot de machine virtuelle à partir de l’interface utilisateur d’OpenShift Virtualization.
Summary: La création d’un snapshot de machine virtuelle via l’interface utilisateur de virtualisation OpenShift échoue si des E/S sont en cours d’exécution dans la machine virtuelle du cluster OCP. ...
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
La création d’un snapshot de la machine virtuelle via l’interface utilisateur de virtualisation OpenShift a échoué.
En vérifiant les journaux du pod virt-handler (espace de noms openshift-cnv), il affiche des erreurs comme ci-dessous :
En vérifiant les journaux du pod virt-handler (espace de noms openshift-cnv), il affiche des erreurs comme ci-dessous :
2023-08-14T02:23:33.722372232Z {"component » :"virt-handler »,"kind » :" »,"level » :"error »,"msg » :"Échec du gel du VMI »,"name » :"rhel9-vm-http-block »,
"namespace » :"rhel-vm »,"pos » :"lifecycle.go :124 »,"reason » :"erreur de serveur.
La commande Freeze a échoué : \"LibvirtError(Code=1, Domain=10, Message='internal error : cannot to execute QEMU agent command 'guest-fsfreeze-freeze' :
failed to open /zoner/sda : Permission denied')\" »,"timestamp » :"2023-08-14T02:23:33.722321Z »,"uid » :"c6894dc7-f29c-43e7-9817-3b12643040d1"}
"namespace » :"rhel-vm »,"pos » :"lifecycle.go :124 »,"reason » :"erreur de serveur.
La commande Freeze a échoué : \"LibvirtError(Code=1, Domain=10, Message='internal error : cannot to execute QEMU agent command 'guest-fsfreeze-freeze' :
failed to open /zoner/sda : Permission denied')\" »,"timestamp » :"2023-08-14T02:23:33.722321Z »,"uid » :"c6894dc7-f29c-43e7-9817-3b12643040d1"}
Cause
Créer une machine virtuelle via la virtualisation OpenShift, le point de montage à partir de la LUN créée n’est pas étiqueté comme approuvé. Ainsi, au cours du processus de snapshot de machine virtuelle, l’agent QEMU ne parvient pas à ouvrir le point de montage (dans cet article de la base de connaissances, le point de montage est /zoner/sda) et l’autorisation lui est refusée alors qu’il tente d’effectuer fsfreeze.
Resolution
Les étapes de résolution ci-dessous supposent que « /zoner/sda » sera le point de montage.
Veuillez utiliser la commande « df -h » et vérifier dans vos journaux d’erreurs le point de montage de rapport d’erreur réel de votre machine virtuelle.
1. Vérifiez que le contexte SELinux du point de montage affiche « unlabeled_t » à l’aide de la commande ci-dessous :
# ls -lZd /zoner/sda/
2. S’il affiche « unlabeled_t », il existe deux options pour le résoudre.
- Option1 : Permet à l’agent QEMU de lire les fichiers non labellisés.
# setsebool -P virt_qemu_ga_read_nonsecurity_files 1
- Option2 : Pour étiqueter le point de montage.
# restorecon -v /zoner/sda/
Produse afectate
APEX Cloud Platform for Red Hat OpenShiftProprietăți articol
Article Number: 000217270
Article Type: Solution
Ultima modificare: 18 sept. 2026
Version: 4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.