OpenShift Virtualization: OpenShift Virtualization UIからVMスナップショットを作成できませんでした。

Summary: OCPクラスター内のVMでIOが実行されている場合、OpenShift Virtualization UIを使用してVMスナップショットを作成すると失敗します。

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

OpenShift Virtualization UIを使用したVMスナップショットの作成に失敗しました。
image.png

virt-handlerポッド(openshift-cnvネームスペース)のログを確認すると、次のようなエラーが表示されます。
2023-08-14T02:23:33.722372232Z {"component":"virt-handler","kind":"","level":"error","msg":"VMIのフリーズに失敗しました","name":"rhel9-vm-http-block",
"namespace":"rhel-vm","pos":"lifecycle.go:124","reason":"サーバーエラー.
コマンドフリーズに失敗しました: \"LibvirtError(Code = 1、Domain = 10、Message = '内部エラー: QEMU エージェント コマンド 'guest-fsfreeze-freeze':
/zoner/sda を開くことができませんでした: アクセス許可が拒否されました')\"","timestamp":"2023-08-14T02:23:33.722321Z","uid":"c6894dc7-f29c-43e7-9817-3b12643040d1"}

Cause

OpenShift Virtualizationを使用してVMを作成する場合、作成されたLUNのマウント ポイントは信頼済みとしてラベル付けされません。そのため、VMスナップショットプロセス中に、QEMUエージェントはマウントポイント(このKBではマウントポイントは/zoner/sda)を開くことができず、fsfreezeを実行しようとすると権限が拒否されます。

Resolution

以下の解決手順では、マウント ポイントとして「/zoner/sda」を想定します。

「df -h」コマンドを使用してエラー ログから確認し、VMの実際のエラー報告マウント ポイントを確認してください。


1.次のコマンドを使用して、マウント ポイントのSELinuxコンテキストに「unlabeled_t」が表示されていることを確認します。

# ls -lZd /zoner/sda/


2.「unlabeled_t」と表示されている場合は、2つの方法で解決できます。

  • オプション1:QEMUエージェントがラベル付けされていないファイルを読み取れるようにするには、次の手順を実行します。
# setsebool -P virt_qemu_ga_read_nonsecurity_files 1

 

  • オプション2:マウント ポイントにラベルを付ける。
# restorecon -v /zoner/sda/

 

Produse afectate

APEX Cloud Platform for Red Hat OpenShift
Proprietăți articol
Article Number: 000217270
Article Type: Solution
Ultima modificare: 18 sept. 2026
Version:  4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.