Isilon: Nie można znaleźć błędu dostawcy dysku podczas ponownego obrazowania
Summary: Błąd "Nie można znaleźć dostawcy dysków" może wystąpić, gdy program ponownego tworzenia obrazu nie może znaleźć dostawcy inicjującego.
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
Podczas procesu przywracania obrazu pojawia się komunikat o błędzie "Cannot find disk provider".
Cannot find disk provider
Traceback (most recent call last):
File "/root/bin/flashdisk_reimage.py", line 2375, in
sys.exit(main(getargs()))
File "/root/bin/flashdisk_reimage.py", line 2251, in main
setup_psi(args)
File "/root/bin/flashdisk_reimage.py", line 1703, in setup_psi
setup_psi_backup_device(args)
File "/root/bin/flashdisk_reimage.py", line 1763, in setup_psi_backup_device
psi_backup_device.providers.init_short()
File "/root/bin/flashdisk_reimage.py", line 1213, in init_short
bootdisk.init_providers(wipe=False)
File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 729, in init_providers
File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 730, in
IndexError: list index out of range
Polecenie potwierdzenia problemu brzmi: isi_bootstrap_devices -b, co daje następujące dane wyjściowe:
isi-bsd# /usr/bin/isi_hwtools/isi_bootstrap_devices -b name: isi-bsd#
Cause
Przyczyną tego problemu jest brak dysku w gnieździe o najwyższym numerze kieszeni A dla węzła.
Resolution
Aby rozwiązać ten problem, wykonaj następujące kroki:
- Włóż dysk do najwyższego numeru gniazda kieszeni A dla węzła. Jeśli dysk został usunięty z powodu usterki, przed kontynuowaniem wymień uszkodzony dysk.
- Jeśli w gnieździe A znajduje się dysk o najwyższym numerze, należy go wymienić na inny dysk w kieszeni. Po ponownym osadzeniu kieszeni ponów próbę ponownego utworzenia obrazu.
Przestroga: Jeśli nie masz pewności lub wątpliwości co do wprowadzenia tych zmian, skontaktuj się z pomocą techniczną firmy Dell lub przejrzyj jej witrynę internetową w celu uzyskania dalszej pomocy.
Uwaga: Ostrożniekonserwuj sprzęt, aby uniknąć uszkodzeń.
Produse afectate
Isilon Gen6, PowerScale A310, PowerScale A3100, PowerScale H710, PowerScale H7100Proprietăți articol
Article Number: 000359362
Article Type: Solution
Ultima modificare: 17 oct. 2025
Version: 1
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.