PowerProtect Data Manager: 재해 복구 복제 타겟 시스템 구성 중 오류 발생 | 박사

Summary: 소스와 타겟 PowerProtect Data Manager 시스템 간의 버전 불일치로 인해 DM5500 소스 시스템에서 재해 복구 구성이 실패합니다.

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Symptoms

DM5500에서 PowerProtect Data Manager 타겟으로 재해 복구를 구성할 때 동기화 작업 구성 단계 중에 프로세스가 실패합니다.

  • 이 문제는 DM5500을 소스로, PowerProtect Data Manager를 타겟으로 했을 때 발견되었지만, 두 DM5500 시스템 또는 두 개의 PowerProtect Data Manager 시스템 간에도 발생할 수 있습니다.
  • 표시된 오류 메시지:
{"code":400,"path":"/api/v2/sync-source-configuration","reason":"Object instance has properties which are not allowed by the schema: ['configType'].","timestamp":1757343876699}
 
스크린 샷 :

시스템 작업에 오류가 표시됨

Cause

소스와 타겟 PowerProtect Data Manager 시스템 간의 버전이 일치하지 않으면 다음과 같은 문제가 발생합니다.

  • 소스: PowerProtect Data Manager 버전 19.19.0-27을 실행하는 DM5500
  • 대상: 버전 19.19.0-15를 실행하는 PowerProtect Data Manager 시스템

최신 DM5500 어플라이언스에는 configType 해당 속성 REST API 이전 대상 시스템 스키마가 인식하지 못하는 페이로드. 그 결과 400 Bad Request 오류 발생 중 /api/v2/sync-source-configuration 통화

로그 분석에는 다음도 표시됩니다.

  • configType: null in the payload
  • Multiple BeanCreationNotAllowedException warnings

이 문제는 버전이 일치하지 않는 경우 DM5500 및 PowerProtect Data Manager 시스템의 모든 조합에서 발생할 수 있습니다.

Resolution

타겟 PowerProtect Data Manager 시스템을 버전 19.19.0-20 이상으로 업그레이드합니다.

  • PowerProtect Data Manager 버전 19.19.0-2019.19.0-27 은 재해 복구 구성과 호환됩니다.
  • 버전이 정렬되면 동기화 작업이 성공적으로 완료됩니다.

Additional Information

/var/log/brs/replmgr/sync.log 보여 줍니다:
 

[c.e.b.s.o.s.i.ConfigureSyncServiceImpl.checkSystemVersion(512)][512 ] -  checkSystemVersion - remote ver: 19.19.0-15 and local ver: 19.19.0-27    <==== PLEASE NOTE Source and Destination revisions are not the same!

Produse afectate

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect DM5500, PowerProtect Software
Proprietăți articol
Article Number: 000386160
Article Type: Solution
Ultima modificare: 21 nov. 2025
Version:  2
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