AppSync: Återställning från AppSync-snapshot kan misslyckas på grund av att tidsgränsen har infaller

Сводка: Återställning från AppSync-snapshot till produktionsvärd misslyckades på grund av att tidsgränsen gick ut.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

En återställningsåtgärd från Det grafiska användargränssnittet för AppSync hänger sig så småningom och misslyckas på grund av ett timeoutfel.

AppSync-händelserna visar:
  
<DATE &TIME>, Restore Copy, fc520a7d-b08d-41ab-9878-70608fdf8ea6, ORCL_000093, <hostyname>, AppSync kunde inte återställa ett eller alla av följande lagringsfilsystem: /my/path/data99,
 
I serverloggarna ser du att tidsgränsen är för öppen:
 
<DATE &TIME> INFO [MATA UTB standard - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> avslutade återställnings-/uppdateringsvolymer på XIO-disksystemet <DATE & TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> slutförd återställ/uppdatera volymer på XIO-disksystemet <DATE &TIME> VARNA [EJB standard - 8] [com.arjuna.ats.arjuna] [AppSync_Server] [] ARJUNA012077: Abort anropade redan avbruten atomisk åtgärd 0:ffff0a25bf41:-396b7557:61391564:19b548 <DATE & TIME> ERROR [EJB default - 8] [org.jboss.as.ejb3.invocation] [AppSync_Server] [] WDIOEJB0034: UTB-invocation failed on component RestoreXIOSnapshotCommandBean for method public boolean com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean.restorePhasePIT(com.emc.archway.context.ExecutionContext,java.util.Set,boolean): javax.ejb.EJBTransactionRolledbackException: javax.transaction.RollbackException: WEJB0447: Transaction 'Local transaction (delegate=TransactionImple < ac, BasicAction: 0:ffff0a25bf41:-396b7557:61391564:19b548 status: ActionStatus.ABORTED >, owner=Local transaction context for provider JBoss JTA transaction provider) har redan återställts till org.jboss.as.ejb3@17.0.1.Final//org.jboss.as.ejb3.tx.CMTTxInterceptor.endTransaction(CMTTxInterceptor.java:114)

 

Причина

Ett antal snapshot var inblandade i återställningsåtgärden som orsakade fördröjning/timeout. Möjlig orsak har inte fastställts, men det kan vara ett prestanda-/långsamhetsproblem på resurser som disksystem och värd.

Разрешение

Om du justerar transaktionens timeoutvärde kan AppSync inte avsluta tidsgränsen under återställningen.
  
  1. Gå till C:\EMC\AppSync\jboss\standalone\configuration\standalone.xml.
  2. Ändra värdet från standardvärdet 300 till det nya värdet 2 400 sekunder – <coordinator-environment default-timeout=2400
  3. Stoppa alla tjänster (EMC AppSync-datalagret och EMC AppSync-säkerhetstjänsten)
  4. Starta tjänsterna (EMC AppSync Datastore Service, EMC AppSync Security Service, EMC AppSync-servertjänsten)

Затронутые продукты

AppSync
Свойства статьи
Номер статьи: 000191827
Тип статьи: Solution
Последнее изменение: 11 May 2026
Версия:  5
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.