Isilon: Schedule reports fail with a status of "Unsuccessful"

Сводка: This KB only applies to InsightIQ version 4.1.0 and newer

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Симптомы

Schedule reports in InsightIQ fail to generate. When looking at the scheduled report page in the InsightIQ UI, the report will have a status of "Unsuccessful".

 

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Причина

Background
The PDF generation in InsightIQ 4.1.0 (and newer) has 3 services involved:
1) The InsightIQ webapp
2) The Celery worker subsystem
3) The RabbitMQ message broker

When a PDF generation job is kicked off, InsightIQ places the task into RabbitMQ. Celery establishes a connection to RabbitMQ, and listens for new tasks. When a task is added to the queue, Celery pulls the task off the queue, and does the actual work of creating the PDF. Once it s done, it ll update RabbitMQ that the task is complete, which is relayed to the InsightIQ webapp.

Cause for "Unsuccessful" PDF generation
The most common cause is that the Celery worker subsystem is unable to establish a connection to the RabbitMQ message broker.

Разрешение

This only applies for InsightIQ version 4.1.0 and newer.

Restart all the services, and optionally empty the RabbitMQ queue.

1) Stop InsightIQ
$ sudo service insightiq stop

2) Ensure that all Celery workers have also stopped. If there's any output, you'll have to manually terminate the celery processes with the kill command.
$ ps auxw | grep celery | grep -v grep

3) Check the queue size, and optionally empty it.
NOTE: Upon correcting the issue, all pending tasks will result in the creation of a PDF. If you have configured InsightIQ to email the PDF after creation, you will get an email for every item in the queue. For example, if there are 30 pending tasks, you will get 30 emails.

# Show the number of pending tasks
$ sudo rabbitmqctl list_queues | grep celery

# OPTIONAL - Empty the queue of all tasks
$ sudo rabbitmqctl purge_queue celery

4) Restart RabbitMQ
$ sudo rabbitmq-server restart

5) Start InsightIQ
$ sudo insightiq start

6) Attempt to generate a new PDF
In the InsightIQ UI, navigate to:
Performance Reporting > Manage Performance Reporting > Schedule Performance Reports
and click "Generate" for any report that currently has a status of "Unsuccessful"

Продукты

Isilon InsightIQ
Свойства статьи
Номер статьи: 000167961
Тип статьи: Solution
Последнее изменение: 15 Dec 2022
Версия:  4
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