PowerStore:データ コレクションが失敗してPowerStore Managerユーザー インターフェイスが誤った情報を報告する
Сводка: PowerStore Managerユーザー インターフェイスにより、誤った値、エラー、ジョブの失敗が報告されます。サポート資料またはサポート データ コレクション(DC)の実行に失敗するか、実行中の状態でスタックします。
Данная статья применяется к
Данная статья не применяется к
Эта статья не привязана к какому-либо конкретному продукту.
В этой статье указаны не все версии продуктов.
Симптомы
症状には次が含まれます。
- PowerStore Managerユーザー インターフェイス(UI)で、サポート資料またはサポート データ コレクション(DC)の実行に失敗するか、実行中の状態でスタックします。CLI (svc_dc run)を介したDCの実行が、次のエラーで失敗します。
- FAILURE, Running too long
- Timed out receiving service data bundle command response from container
- ボリュームに0GBの容量が表示されます。
- オブジェクト(ボリュームなど)を作成または削除できません。
- ボリュームを拡張できません - エラー 0xE0A080030019。
- 保護ポリシーが機能しなくなり(新しいスナップショットが作成されず、古いスナップショットが失効しない)、レプリケーション検証が失敗します。
- SSHステータスを表示または変更できません。Error: There was an error retrieving this information.Unknown property is_ssh_enabled requested.(0xE04040020002)」
- LDAPドメイン接続エラー
- ルート パーティションがいっぱいである、または領域が不足しているアラートが発生します。一時DCファイルがセカンダリー ノード上の/cyc_var/cyc_service/tmpからクリーンアップされず、ルート パーティションがいっぱいになる可能性があります。システムは次の警告を生成します:「Root partition usage of node X has exceeded Y% (codes: 0x00400601 or 0x00400602)」
- 極端なケースでは、ルート パーティション領域の問題を解決するために迅速なアクションが実行されないと、セカンダリー ノードがサービス モードになる場合があります。
- システム チェック>のモニタリング >Firemanコマンドが失敗し、システム チェックの実行が失敗します。(0xE0F010200004)」エラーで失敗します。
PowerStore Managerから見たDCに関する問題の例:

PowerStore Managerに表示されるシステム チェック エラーの例:

Причина
systemdログイン セッションが多数リークしたことにより、サービス コンテナ内のメモリー リークが発生します。サービス コンテナ内のfiremanサービスは、メモリー不足状態のため、DC収集中に強制終了されます。
firemanサービスが強制終了された後に、システムが障害を検出しないと、firemanサービスは停止したままになります。
firemanサービスが強制終了された後に、システムが障害を検出しないと、firemanサービスは停止したままになります。
Разрешение
修正
この問題を回避するための修正は、PowerStoreOS 2.1.1.0-1649887に含まれます。アップグレードすることを推奨します。この修正は、PowerStoreOSバージョン2.1.1.0リリース ノート リビジョンA03以降に記載されています。
| 問題ID | 機能領域 | 説明 |
| MDT-361718 | PowerStore Manager(GUI) | コントロール パスまたは管理リソースに問題があるため、時間の経過とともにPowerStoreシステムのユーザー インターフェイスが機能低下する可能性があります。この機能低下により、応答が遅くなったり、PowerStore Manager (UI)がデータを収集できなくなったりする可能性があります。 |
対策
注:この回避策は、PowerStore Tモデルのみを対象としています。PowerStore Xには、サービスを再起動する前に実行する必要がある追加の要件と手順があります。
問題がすでに発生している場合は、アップグレードを試みる前に、 Dellテクニカル サポート または認定サービス担当者に連絡し、このナレッジベース記事IDを伝えてください。
すでに存在するこの問題を解決するには、2つのサービスを再起動する必要があります。
- 影響を受けるノード上のサービス コンテナ。
- サービス コンテナの再起動には約10分かかります。
- 影響を受けるノードのサービス コンテナ(sshまたはcli)へのアクセスが一時的に失われる以外は、システムへの影響はありません。
- コントロール パス(CP)または管理サービス。
- 再起動には約5分かかります。
- PowerStore Managerユーザー インターフェイスへのアクセスが一時的に失われる以外、システムへの影響はありません。
数分後、セカンダリー ノードのルート パーティションの領域が通常のレベルに低下します。
/cyc_cfsパーティションが85%を超えている場合は、PowerStore Managerのユーザー インターフェイスから古いDCを削除します。
サービスを再起動すると、次のようなアラートが表示されることがあります。
- SupportAssist接続アラート。
- レプリケーションRPOが満たされていないアラート。
- スナップショットの自動削除アラート。
Дополнительная информация
問題の特定
リークしたログイン セッションが多数あることを確認します(この数が5000を超える場合は問題があります)。[SVC:service@xxxxxxx-A ~]$ ll /run/systemd/system/ | wc -l |
DCが「FAILURE, Running too long」エラーで失敗します。
[SVC:service@xxxxxxx-A user]$ svc_dc list e62c17be-7716-49ef-a0b0-7365db383e6e |
firemanプロセスがプライマリー ノードに存在しない場合、DCは「Timed out receiving service data bundle command response from container」エラーで失敗します。
[SVC:service@xxxxxxx-B user]$ svc_dc list 7ad948cb-5029-422f-b4dc-5bf2f9abf512 |
Затронутые продукты
PowerStoreПродукты
Storage, Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000TСвойства статьи
Номер статьи: 000193605
Тип статьи: Solution
Последнее изменение: 29 May 2024
Версия: 21
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.