NetWorker: "Nie udało się otworzyć pliku blokady: Odmowa uprawnień "Błąd zaobserwowany podczas uruchamiania dowolnego polecenia w nsr

Сводка: Z powodu problemów z uprawnieniami nie można korzystać z żadnych narzędzi wiersza poleceń NetWorker.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Polecenie mminfo kończy się niepowodzeniem z następującym błędem:
136611:mminfo: Failed to open the lock file: Permission denied
144502:nsrd: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.
167325:mminfo: Unable to connect to media database server on host <NW-Server-Name>: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.

Dotyczy to również nsrcapinfo, nsradmin, nsrlogin, nsrauthtrust itd.

Причина

.administrator.lck nie ma wystarczających uprawnień na hoście serwera NetWorker.

Разрешение

Zmiana uprawnień w pliku blokady nsrlogin w /nsr/tmp/sec/tokens

Windows:

  1. Przejdź do /nsr/tmp/sec/tokens
  2. Znajdź plik ".nsrlogin.localadmin.lck" (jest to plik ukryty, w systemie Windows kliknij opcję wyświetl, a następnie pokaż ukryty).
  3. Zmodyfikuj uprawnienia do pliku dla administratora lokalnego, aby mieć pełną kontrolę.

Linux:

  1. cd /nsr/tmp/sec/tokens
  2.  Wpisz "ls -lat", aby wyświetlić listę wszystkich ukrytych plików i wyświetlić uprawnienia.
  3. Zmodyfikuj uprawnienia plików, aby mieć uprawnienia do odczytu, zapisu i wykonywania.
Свойства статьи
Номер статьи: 000220446
Тип статьи: Solution
Последнее изменение: 23 Feb 2024
Версия:  2
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.