NetWorker: »Не вдалося відкрити файл блокування: Permission denied " помилка під час виконання будь-якої команди в nsr

Сводка: Неможливо використовувати будь-які утиліти командного рядка NetWorker через проблеми з дозволами.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Команда mminfo завершується помилкою з такою помилкою:
136611:mminfo: Failed to open the lock file: Permission denied
144502:nsrd: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.
167325:mminfo: Unable to connect to media database server on host <NW-Server-Name>: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.

Це також стосується nsrcapinfo,nsradmin, nsrlogin, nsrauthtrust тощо.

Причина

Файл .administrator.lck не має достатнього дозволу на хост сервера NetWorker.

Разрешение

Зміна прав доступу до файлу блокування nsrlogin у /nsr/tmp/sec/tokens

Windows:

  1. Перейдіть до /nsr/tmp/sec/tokens
  2. Знайдіть файл ".nsrlogin.localadmin.lck" (Це прихований файл, у Windows натисніть перегляд, потім покажіть прихований).
  3. Змініть дозвіл на доступ до файлів, щоб локальний адміністратор мав повний контроль.

Linux:

  1. cd /nsr/tmp/sec/tokens
  2.  Введіть "ls -lat", щоб ви могли перерахувати всі приховані файли та показати права доступу.
  3. Змініть дозволи на доступ до файлів, щоб мати дозволи на читання, запис і виконання.
Свойства статьи
Номер статьи: 000220446
Тип статьи: Solution
Последнее изменение: 23 Feb 2024
Версия:  2
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.