DDBEA 4.5: con SQL 2014 y 2016 en el mismo sistema: no se puede iniciar sesión en la instancia de SQL Server.

Сводка: El plug-in de Microsoft APP Agent de DDBEA instalado en SQL Server 2014 y 2016 presenta un problema en el cual falla algún respaldo: no se puede iniciar sesión en la instancia de SQL Server. ...

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Data Domain Backup Enterprise Agent: el plug-in de DDBEA no puede realizar respaldos de SQL Server.
 

ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.

ddbmsqlsv: Unable to complete the SQL connection

Причина

El entorno
SQL Server 2014 está instalado y una instancia de SQL 2014 está en ejecución.  SQL Server Management Studio (SSMS) usa la versión 2014. 
En el mismo sistema, también se instala el software SQL Server 2016.

Se verificaron los permisos del usuario que inició sesión; dicho usuario tiene todos los permisos necesarios. 
El usuario puede realizar respaldos nativos de SQL desde las herramientas SSMS, OSQL y SQLCMD.

La investigación reveló, en algún momento después de que se instaló SQL Server 2016, que tampoco.
  •  El software SQL 2016 se desinstaló parcialmente (pero no completamente)
  •  O bien, se eliminaron algunos archivos de la instalación de SQL 2016.      Esto provocó la eliminación de los controladores de SQL 2016 ADO.Net.  ** Estos controladores son necesarios para que DDBEA se conecte a la instancia de SQL Server.
  • La instancia de SQL Server y SSMS, que son versión 2014, no tienen problemas.
  • El software SQL Server 2016 no se eliminó de forma correcta o completa, lo que provocó que cualquier instalación de DDBEA intentara conectarse mediante controladores faltantes de SQL 2016 ADO.net.
Cualquier respaldo de cualquier base de datos falla con el error. 
 ddbmsqlsv NSR critical Cannot login to SQL Server Default Instance.
 ddbmsqlsv: Unable to complete the SQL connection

Разрешение

Para resolverlo,

primero desinstale DDBEA.   A continuación, realice una de las siguientes acciones:

A) si la versión de SQL requerida es 2014, desinstale y vuelva a instalar SQL Server 2014

B) si la versión de SQL requerida es 2016 y no se desinstaló correctamente, realice una instalación nueva de SQL Server 2016. 

Después de lo anterior, reinstale DDBEA.
Свойства статьи
Номер статьи: 000161829
Тип статьи: Solution
Последнее изменение: 27 May 2024
Версия:  4
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.