Data Domain:新しいデータベース名にリストアするときにDDBMA SQLクラスター データベースのリストアが失敗する

Сводка: DDBMA: SQLクラスター データベースのリストアが、「disk resource containing the file is not present in the cluster group」で失敗します。

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

エラーメッセージ:
ddbmsqlrc PowerProtect Data Manager Critical Cannot use file 'M:\SQLEU_Data1\SQL_Data\DB.MDF' for clustered server. Only Formatted files on which the cluster resource of the server has a dependency can be used. Either the disk resource containing the file is not present in the cluster group or the cluster resource of the SQL server does not have a dependency on it. 
ddbmsqlrc PowerProtect Data Manager critical (Error: 5184)
ddbmsqlrc PowerProtect Data Manager critical unknown XBSA error 1359 (0x54f)

Причина

この障害は、共有クラスター ドライブ上の新しいデータベース名にリストアしようとすると発生します。SQL Serverリソースは、そのディスクに依存しません。

Разрешение

1.SQLサービスが必要なDB管理者権限で実行されていることを確認します。
2.データベース アカウントにロックボックス フォルダーに対するフル 権限があることを確認します。
3.データベース アカウントがファイル グループ フォルダーに対するフル権限を持っていることを確認します。
4.SQL Serverへの依存関係としてディスクを追加します。以下のガイドラインに従ってください。

SQL Serverに依存関係としてディスクを追加するには、共有クラスター ディスクをSQL Serverリソースと同じグループのクラスター管理者に配置する必要があります。共有クラスター ディスクを移動するには、SQL Serverグループに移動するディスクを選択し、そのリソースを右クリックします。グループの変更 をクリックします。ディスクがSQL Serverリソースが存在する同じグループに入ったら、次の手順に従ってSQL Serverの依存関係として追加します。
  1. クラスター管理者を開きます。
  2. SQL Serverデータベースを含むすべての物理ディスク リソースが、SQL Serverリソースと同じグループにあることを確認します。
  3. SQL Serverリソースを右クリックし、 オフラインにする を選択してリソースをオフライン状態にします。
  4. SQL Serverリソースを右クリックし、[ プロパティ ]を選択します。
  5. Dependencies タブを選択します。
  6. Modify を選択して、そのリソースの依存関係リストにディスクを追加します。
  7. SQL Serverリソースをオンラインに戻し、その共有クラスター ディスクにSQL Serverファイルを配置します。

Затронутые продукты

Database App Agent, DD Boost for Enterprise Applications, Microsoft App Agent
Свойства статьи
Номер статьи: 000218849
Тип статьи: Solution
Последнее изменение: 19 May 2026
Версия:  5
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.