Avamar. MCS получает сообщения «OutOfMemory»

Сводка: Сервер консоли управления Avamar Management Console Server (MCS) получает сообщения «OutOfMemory» из-за большого размера файла NVRAM от виртуальной машины.

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Запланированное резервное копирование VMware и физических компонентов не отвечает.

Они могут отображаться в окне активности администратора Avamar как запущенные, но без каких-либо изменений в байтах выполнения.

Сервер консоли управления (MCS) сообщает о состоянии нехватки памяти, и пользовательский интерфейс может медленно реагировать.

Клиенты VMware долго не регистрируются.

Причина

Во время резервного копирования виртуальных машин MCS загружает файлы энергонезависимой оперативной памяти (NVRAM) в javaheap , чтобы прочитать конфигурацию BIOS.

Файл NVRAM находится в папке VMware *.vmdk файлов, которые находятся в хранилище данных.

Иногда размер файла NVRAM, который обычно составляет всего несколько Кбайт (менее 10 Кбайт), увеличивается примерно до 1 Мбайт или более.

Этого достаточно, чтобы вызвать MCS javaheap для нехватки памяти.

 

Разрешение

1. Войдите в Avamar Utility Node и загрузите ключи администратора. Инструкции по загрузке ключей см . в Avamar. Как выполнить вход в Avamar Server и загрузить разные ключи.

2. Проверьте, является ли javaheap уже установлено на уровне 1,5 ГБ, что обозначается "-Xmx1536m" в выводе ниже:

Примечание. Значение «Xmx1536m» может изменяться в зависимости от использования памяти.  
 
ps -elf | grep java | grep mcserver
0 S admin    13623     1  2  76   0 - 556102 -     16:54 pts/0    00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
 

3. Убедитесь, что в журнале отображаются сообщения о нехватке памяти (из-за потенциально большого объема памяти NVRAM).

grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Unknown Source)
        at java.io.ByteArrayOutputStream.write(Unknown Source)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
        at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
        at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
        at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
        at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
        at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
 

4. Проверьте, какие клиенты имеют большой объем памяти NVRAM.

grep "nvramContent\=\"null\"" mcserver.log.*
 

В этом образце выходных данных клиента "Company_1_Email-PDB reports""nvramContent="null"':

FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg" 
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea" 
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621" 
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives> 
<flag type="string" name="encrypt" value="proprietary"  />  <flag type="string" name="encrypt-strength" value="cleartext"  />  <flag type="string" name="expire" 
value="1353034800"  />  <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE""  nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" 
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000" 
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
Примечание. Несколько клиентов могут сообщать о значении null nvramcontent value, поэтому все экземпляры должны быть проверены.
 

5. После того как клиент или клиенты с большим объемом NVRAM будут идентифицированы по журналам, выполните следующие действия.

a. Перезагрузите клиент, чтобы создать новый файл NVRAM.

B. Если проблема возникла с тем же клиентом, создайте сервисную заявку в службу технической поддержки Dell Technologies.

6. Если сообщение об ошибке сохраняется, см . Avamar. Код признака 22402 - Описание: Не удалось сохранить данные сервера консоли на сервере (путь решения) для дополнительного поиска и устранения неисправностей.

Затронутые продукты

Avamar

Продукты

Avamar
Свойства статьи
Номер статьи: 000036926
Тип статьи: Solution
Последнее изменение: 07 Oct 2025
Версия:  8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.