Avamar. «Не удалось сохранить данные консольного сервера на сервер» из-за сканеров портов, что приводит к высокой загрузке ЦП Java

Сводка: Сканеры портов вызывают высокую загрузку ЦП Java, что приводит к ошибке очистки сервера консоли управления (MCS): «Не удалось сохранить данные сервера консоли на сервере».

Данная статья применяется к Данная статья не применяется к Эта статья не привязана к какому-либо конкретному продукту. В этой статье указаны не все версии продуктов.

Симптомы

Это событие можно зарегистрировать как событие домашнего вызова, событие пользовательского интерфейса MC или просмотреть в сеансе PuTTY на служебном узле Avamar:

Symptom: 22402, Desc: Could not save console server data to server.
 

Процесс java на узле Avamar Utility Node работает на 100% ЦП или выше.

top
top - 10:57:10 up 140 days, 19:57,  2 users,  load average: 2.55, 2.52, 2.48
Tasks: 187 total,   1 running, 186 sleeping,   0 stopped,   0 zombie
Cpu(s): 74.5%us,  0.2%sy,  0.0%ni, 25.4%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:     12028M total,    10789M used,     1238M free,      187M buffers
Swap:     4086M total,       68M used,     4018M free,     7507M cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
12108 admin     20   0 1720m 1.3g  11m S  299 10.9 112556:00 java
13476 admin     20   0 1125m 541m  11m S    0  4.5 157:08.53 java
14055 root      20   0 1485m 158m  10m S    0  1.3 184:58.50 java
 

В /usr/local/avamar/var/mc/server_log/axis2.log.

2013-01-24 23:01:42,517 [1031746922@qtp-1453087591-170] ERROR org.apache.axis2.engine.AxisEngine  - The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
        at org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:65)
        at org.apache.axis2.engine.Phase.invoke(Phase.java:334)

2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar

Причина

Высокий уровень использования Java на узле Avamar Utility Node может привести к сбою сброса (резервного копирования) сервера консоли управления (MCS).

Увеличение постоянной загрузки ЦП после сканирования портов для отправки строк ненужных запросов в веб-службу MC через порт 9443.

В результате MCS становится недоступен для резервного копирования, что может привести к сбою очистки.

 

Разрешение

1. Убедитесь, что сканер портов (например, Nessus) сканирует любой из узлов Avamar. Если возможно, отключите сканирование портов на служебном узле Avamar.

2. Войдите в Avamar Utility Node в качестве администратора и загрузите ключи Avamar: Как выполнить вход в Avamar Server и загрузить разные ключи.

3. Используйте top команда, чтобы проверить, высока ли загрузка процессора java (более 100% является высокой):

top

 

 

4. Проверьте, не появляются ли в журнале axis сообщения порта 9443:

grep 9443 /usr/local/avamar/var/mc/server_log/axis2.log
2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar
 

5. Проверьте, когда был запущен процесс java.

ps -ef | grep java

 

    • Если дата процесса java совпадает с данными из шага 4 (в данном примере 2014-04-09), процесс может находиться в состоянии «не отвечает»
    • Если дата процесса java нова или не совпадает, прекратите использование этого решения

6. Переключитесь на привилегии root:

su - 

 

 

7. Завершите java-процесс, вызвавший нарушение:

a. Найдите идентификатор процесса java (PID):

ps -ef | grep java
 

b. Завершите процесс.

kill -9 <PID>
 

8. Выйдите из системы с привилегиями root:

exit
 

9. Остановите и запустите MCS с помощью Avamar. Перезапуск Management Control Server (MCS)

10. Убедитесь, что очистка MCS работает и не возникают ошибки «22402».

mcserver.sh --flush
 

11. Если сообщения об ошибках не исчезают, см. Avamar — код признака 22402 — не удалось сохранить данные консольного сервера на сервере (путь решения) для дополнительного поиска и устранения неисправностей.

Если требуется дополнительная помощь, создайте сервисную заявку.

Затронутые продукты

Avamar

Продукты

Avamar
Свойства статьи
Номер статьи: 000163004
Тип статьи: Solution
Последнее изменение: 23 Sep 2025
Версия:  8
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.