NetWorker vProxy-Backup schlägt mit "Unable to create non-quiesced snapshot after a retry attempt: Detected an invalid snapshot configuration"
Сводка: Die NVP-Integration (NetWorker VMware Protection) wird mit der vProxy-Appliance konfiguriert. Das Backup der virtuellen Maschine (VM) für einige VMs schlägt mit einer ungültigen Snapshot-Konfigurationsfehlermeldung fehl. In der vSphere Web Client Snapshot-Ansicht für die VM werden keine verfügbaren Snapshots für die VM angezeigt. ...
Данная статья применяется к
Данная статья не применяется к
Эта статья не привязана к какому-либо конкретному продукту.
В этой статье указаны не все версии продуктов.
Симптомы
Das Backupsitzungsprotokoll zeigt Folgendes an:
Das VMNAME_vmware-###.log zeigt Folgendes an:
...
YYYY-MM-DD HH:MM:SS INFO: [167] Creating snapshot of virtual machine ...
YYYY-MM-DD HH:MM:SS ERROR: [167] Unable to create non-quiesced snapshot after a retry attempt: Detected an invalid snapshot configuration.
YYYY-MM-DD HH:MM:SS ERROR: [167] Unable to create snapshot.
YYYY-MM-DD HH:MM:SS INFO: [167] Enabling storage migration of virtual machine ...
YYYY-MM-DD HH:MM:SS INFO: [167] Storage migration successfully enabled: "vm-4030" @ "my_vm_name.my_domain.com"
YYYY-MM-DD HH:MM:SS WARN: [167] Virtual machine left locked by backup session because cleanup is required. Snapshot was not removed.
...
Das VMNAME_vmware-###.log zeigt Folgendes an:
...
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk: Failed to branch disk: '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' -> '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000004.vmdk' : The file already exists (39)
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DiskLib_IsVMFSSparseSupported: vmfssparse is not supported on /vmfs/volumes/DATASTORE_UUID/VM_NAME: f532.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE : DiskLibCreateCreateParam: Selecting the default child type as SeSparse for /vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE : DiskLibCreateCreateParam: seSparse grain size is set to 8 for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk'
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk failed for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' : A required file was not found (7).
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-VMFS : "/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-flat.vmdk" : closed.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranch failed: A required file was not found (7).
...Причина
Das Problem kann auftreten, wenn verwaiste temporäre Snapshot-Deskriptordateien im Datenspeicherverzeichnis der virtuellen Maschine vorhanden sind. Diese Snapshot-Deskriptordateien werden als ####.-000001.vmdk, ####.-000001-sesparse.vmdk und ####.-000001-ctk.vmdk angezeigt.
Разрешение
Die Schritte zum Entfernen der verwaisten temporären Snapshot-Deskriptordateien sind in der VMware Knowledge Base 80246 dokumentiert.
https://kb.vmware.com/s/article/80246
https://kb.vmware.com/s/article/80246
- Durchsuchen Sie den Datenspeicher der betroffenen VM, um die temporären Deskriptordateien zu identifizieren. Name kann wie folgt angezeigt werden:
- ####-000001.vmdk
- ####-000001-sesparse.vmdk
- ####-000001-ctk.vmdk
- Identifizieren Sie einen Ordner mit ausreichend Speicherplatz, um die temporären Deskriptordateien zu verschieben und einen neuen Ordner zu erstellen.
- vmfs/volumes/VM_####_DATASTORE5/FOLDERNAME/
- Verschieben der temporären Deskriptordateien in den neu erstellten Ordner
- Erstellen Sie einen Snapshot der VM und erstellen Sie den Snapshot erfolgreich.
- Löschen Sie alle Snapshots mit der Option "Delete All Snapshots".
- Snapshot löschen validieren.
- Überprüfen Sie, ob sich keine Deskriptordateien im VM-Datenspeicherordner befinden.
- Lassen Sie die geplanten vProxy-Backups ausführen.
Дополнительная информация
Затронутые продукты
NetWorkerСвойства статьи
Номер статьи: 000196313
Тип статьи: Solution
Последнее изменение: 23 Oct 2024
Версия: 3
Получите ответы на свои вопросы от других пользователей Dell
Услуги технической поддержки
Проверьте, распространяются ли на ваше устройство услуги технической поддержки.