VNX: Помилка VC CAVA: 3: 32: Сервер 'x.x.x.x' видав помилку 'FAIL' при перевірці файлу
Zhrnutie: Помилки в журналах переміщення даних свідчать про те, що служба VC не відсканувала файл
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
Під час перевірки на вірус у журналах з'являється помилка, що VC-сервіс не перевірив її:
2016-03-29 11:38:44: VC: 3: 32: Сервер 'x.x.x.x' видав помилку 'FAIL' при перевірці файлу '\root_vdm_id\mount_path\filename.ext'
Príčina
Повідомлення 'FAIL' виникає, коли відкривається запит на сканування (VC-сервіс на дата-мувері надсилає запит серверам CAVA), і коли CAVA-сервер намагається його відкрити, файл не знаходиться. Це означає, що файл було видалено до того, як його можна було відсканувати. Є кілька сценаріїв, де це може статися:
- Один із способів — якщо файл був файлом cookie, тимчасовим або файлом блокування. Microsoft Office, наприклад, створює тимчасові файли у форматі ~$<original_filename.xxxx>. Ці файли зазвичай зникають, коли файл збережено або закрито, і якщо це відбувається швидко, файл може зникнути до того, як його відсканують, що призводить до повідомлення FAIL у журналі переміщення даних. Імена файлів, які не проходять сканування, зазвичай вказують на це як джерело проблеми.
- Ще один спосіб, яким це може статися — якщо файл має особливу «розпозицію». У SMB та SMB2 користувач може встановити диспозицію «видалити при закритті» при відкритті файлу. Якщо файл, який направляється для сканування, відкриває інший користувач із цим налаштуванням, файл видаляється до того, як його можна буде відсканувати, що призводить до повідомлення FAIL у журналах переміщення даних. Цю опцію можна побачити у трасуванні пакетів, дивлячись на виклики SMB 'Create' або 'SetInfo', але вона буде встановлена користувачем, який виконує видалення, а ймовірно не серверами CAVA. Це може ускладнити роботу, оскільки потрібно контролювати звичайний трафік (не лише AV-сервер), щоб визначити, хто встановлює прапорець.
Riešenie
Найкраще рішення — зупинити видалення файлу (зовнішніми користувачами, які його видаляють). Це може означати вимкнення використання тимчасових файлів в офісі або зберігання інших тимчасових файлів чи cookie у локальній директорії замість спільної. Якщо це неможливо, тоді змініть viruschecker.conf, щоб виключити такі типи файлів із перевірки, змінивши рядок 'excl' на виключення ~$*.* (для офісних файлів), *.tmp або будь-якого іншого розширення, яке може спричиняти ці помилки.
viruschecker.conf:CIFSserver=CIFS server on data mover
>addr=<configured CAVA servers>
excl=~$*.*:*.accdb:*.laccdb:*.ldb:*.mdb:*.pst:*.tmp:????????
<
маски=*.*
вимкнення=перевірка на вірус
viruschecker.conf:CIFSserver=CIFS server on data mover
>addr=<configured CAVA servers>
excl=~$*.*:*.accdb:*.laccdb:*.ldb:*.mdb:*.pst:*.tmp:????????
<
маски=*.*
вимкнення=перевірка на вірус
Ďalšie informácie
Додаткові ресурси:
функція https://wiki.wireshark.org/SMB2/SMB2_FILE_DISPOSITION_INFO
(SMB2_FILE_DISPOSITION_INFO адреси «видалити при закритті»)
Dotknuté produkty
VNX1 SeriesProdukty
Celerra, VNX1 Series, VNX2 SeriesVlastnosti článku
Číslo článku: 000052379
Typ článku: Solution
Dátum poslednej úpravy: 25 máj 2026
Verzia: 4
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.