NetWorker: Errore durante il caricamento delle librerie condivise: libncurses.so.5

Zhrnutie: Su Linux RHEL 8.0 e versioni successive, potrebbero essere visualizzati i seguenti errori durante l'avvio di alcuni servizi NetWorker sul server NetWorker dopo l'installazione.

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

I daemon di NetWorker non si avviano con il seguente errore in daemon.raw:
daemon.raw dei registri dal server NW

Príčina

Su Red Hat 8 e versioni successive, il binario libncurses.so.5 non è disponibile per impostazione predefinita. 


Di seguito sono riportate le versioni delle librerie dipendenti disponibili in base alle piattaforme.
RHEL 7 ha libncurses.so.5 come libreria predefinita.
RHEL 8 halibncurses.so.6.1 come libreria predefinita (tuttavia, libncurses.so.5 è anche disponibile per il download dal Red Hat Repository.)
RHEL 9 ha libncurses.so.6.2 come impostazione predefinita.

Riešenie

Su RHEL 8.x e versioni successive, cercare i binari esistenti libncurses.so.6.x e libtinfo.so.6.x come parte del pacchetto RPM ncurses-libs-6.x e creare un soft link come mostrato di seguito.

Per RHEL 8.x, utilizzare questa opzione:

ln -s "/usr/lib64/libncurses.so.6.1" "/usr/lib64/libncurses.so.5"
ln -s "/usr/lib64/libtinfo.so.6.1" "/usr/lib64/libtinfo.so.5"

Per RHEL 9.x, utilizzare questa opzione:

ln -s "/usr/lib64/libncurses.so.6.2 "/usr/lib64/libncurses.so.5"
ln -s "/usr/lib64/libtinfo.so.6.2" "/usr/lib64/libtinfo.so.5"

 

 

 

Ďalšie informácie

Questa soluzione alternativa consente di risolvere questa compatibilità di NetWorker Server 19.9 per i sistemi operativi Red Hat versioni 8.x e 9.x:

Compatibilità con i server Snips from NWCompatibilità con i server Snips from NW

 
Vlastnosti článku
Číslo článku: 000220485
Typ článku: Solution
Dátum poslednej úpravy: 25 máj 2026
Verzia:  4
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.