Data Domain: wyciek pamięci wtyczki boostfs

Zhrnutie: Procesy BoostFS mogą z czasem zużywać nadmierną ilość pamięci fizycznej, szczególnie w środowiskach z wieloma montowaniami. Może to prowadzić do zwiększonego ogólnego użycia pamięci systemowej i pogorszenia wydajności systemu. ...

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

Stopniowy wzrost wykorzystania pamięci po zamontowaniu BoostFS
Procesy BoostFS zużywające znaczną część pamięci systemowej.
Większe wykorzystanie pamięci w przypadku skonfigurowania wielu montowań BoostFS.
Spadek wydajności systemu w czasie
Użycie pamięci wydaje się stale rosnąć, ale nie jest zwalniane.

Príčina

Problem jest spowodowany wyciekiem pamięci w bibliotekach skrytek innych firm zintegrowanych z systemem plików BoostFS.
BoostFS używa mechanizmu skrytki do bezpiecznego przechowywania poświadczeń dla jednostek pamięci masowej Data Domain.
Podczas operacji, takich jak montowanie i we/wy, wpisy skrytki są wielokrotnie weryfikowane.
Każda walidacja powoduje alokację pamięci przez bibliotekę skrytki.
Ta przydzielona pamięć nie jest prawidłowo zwalniana, co prowadzi do wycieku pamięci.
Wraz z upływem czasu i przy wielu montowaniach zużycie pamięci znacznie wzrasta.
Wersje, których dotyczy problem:
BoostFS 7.12 i starsze są dotknięte problemem.

Riešenie

Uaktualnij BoostFS do wersji 7.13 lub nowszej, w której ten problem został rozwiązany.
Po uaktualnieniu monitoruj wykorzystanie pamięci, aby potwierdzić stabilizację.

Jeśli natychmiastowa aktualizacja nie jest możliwa:
Zminimalizuj liczbę jednoczesnych montowań BoostFS tam, gdzie jest to możliwe.
Okresowo uruchamiaj procesy BoostFS jako tymczasowe środki zaradcze.

Dotknuté produkty

Data Domain
Vlastnosti článku
Číslo článku: 000480507
Typ článku: Solution
Dátum poslednej úpravy: 23 jún 2026
Verzia:  1
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.