PowerFlex: SSL Certificate Verify Failed - Failed to Bootstrap
Zhrnutie: SSL Certificate Verify Failed - Failed to Bootstrap
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
PostgreSQL Leader Logs
host=1.2.3.4, 27737: LOG: could not accept SSL connection: sslv3 alert certificate expired
2026-05-07 05:54:33,942 INFO: no action. I am (postgres-ha-cmo), the leader with the lock
postgres, 2026-05-07 05:54:34 UTC, app=, db=, user=, host=, 29754: LOG: received SIGHUP, reloading configuration files
postgres, 2026-05-07 05:54:38 UTC, app=[unknown], db=[unknown], user=[unknown],
host=1.2.3.4, 27774: LOG: could not accept SSL connection: certificate verify failed
- Bootstrap process was blocked until certificates were renewed
- PostgreSQL replica failed to start succefully
PostgreSQL Replica Logs** (postgres-ha-cmo/database/logs.txt):
```
2026-05-07 05:55:14,743 INFO: No PostgreSQL configuration items changed, nothing to reload.
2026-05-07 05:55:14,746 INFO: Lock owner: postgres-ha-cmo; I am postgres-ha-cmo
2026-05-07 05:55:14,773 INFO: trying to bootstrap from leader 'postgres-ha-cmo'
2026-05-07 05:55:23,905 INFO: Lock owner: postgres-ha-cmo; I am postgres-ha-cmo
Príčina
PGO operator failed to renew the certificates
Riešenie
Restart the cert-manager
kubectl rollout restart deployment cert-manager -n powerflex
Expected result:
- Cert-manager pods restarted
- All managed certificates renewed
- PostgreSQL pod certificates renewed
- Replica pod successfully bootstrapped
- System returned to normal operation
Dotknuté produkty
PowerFlex rack, ScaleIOVlastnosti článku
Číslo článku: 000504990
Typ článku: Solution
Dátum poslednej úpravy: 14 sep 2026
Verzia: 2
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.