NetWorker:“限制克隆数”为 0,未完成并显示“NSR info Media Waiting event:Waiting for 1 writable on <Storage_node_name>”

摘要: NetWorker:“限制克隆数”为 0,克隆未完成,并显示“NSR info Media Waiting event:正在等待 1 个可写卷到备份池' disk(s) on

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

克隆未完成,并显示以下消息:

"NSR info Media Waiting event: Waiting for 1 writable volume(s) to backup pool '<Pool_name>' disk(s) on <Storage_node_name>"

在守护程序日志中:

Linux:/nsr/logs/daemon.raw
窗:<INSTALL_DRIVE>:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
NetWorker:如何使用nsr_render_log呈现.raw日志文件

nsrd NSR info Media Info: Suggest manually labeling a new writable volume for pool '<Pool_name>'
nsrd NSR info Media Waiting event: Waiting for 1 writable volume(s) to backup pool '<Pool_name>' disk(s) on <Storage_node_name>

克隆组将“限制克隆数”设置为默认值 0。值 0 定义无限制。

克隆组的“包括以前存储集”设置为 5 天。因此,相同的SSID被选择五次。

通过 nsradmin ,可以找到“限制克隆数”为 0 的组列表。

NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> sho name
nsradmin> p type:NSR Protection Group;work item query: maximum instances=0

NetWorker Administration Guide》中记录了 https://www.dell.com/support/product-details/product/networker/docs

“每个克隆卷只能包含克隆存储集的一个实例,即使克隆作未成功完成也是如此。例如,如果要创建存储集的三个克隆拷贝,NetWorker 必须将每个克隆存储集写入单独的卷。因此,您将需要三个单独的卷。

mminfo 克隆池的命令显示克隆数与克隆池中标记的卷数相同。如果有两个设备标记到池,则 mminfo 命令为:

mminfo -avot -q "copies>2,pool=<Pool_name>" | more

由于源卷上有一个原始副本,因此副本数将为 3。这可以通过向报告添加副本来证明:

[root@<host>]# mminfo -avot -q "copies>2,pool=<Pool_name>" -r "volume,type,client,savetime(25),
totalsize(1),ssid,fragflags,level,name,copies" | head -2
 volume        type   client           date     time  total ssid      fl   lvl name                          copies
<Volume_name>   Data Domain <Client_name> mm/dd/yyyy hh:mm:ss PM <Size> <SSID> <Flag> <Level> <Save_set_name>  3
[root@<host>]#

原因

克隆组配置为多次选择相同的 SSID,并且克隆组未限制要保存的副本数。

解决方案

如果只需要一个 SSID 拷贝,请将克隆组的“限制克隆数”属性重新配置为 1。 

克隆组限制克隆的数量

如果有两个设备,并且每个克隆设备上都需要一个拷贝,则“限制克隆数”属性将为 2。

受影响的产品

Data Backup & Protection Storage, NetWorker
文章属性
文章编号: 000036100
文章类型: Solution
上次修改时间: 16 5月 2025
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。