SourceOne 电子邮件管理 — 活动无法处理来自 Microsoft Exchange 2013 上托管的邮箱的某些邮件,从而导致作业失败

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状



使用 SourceOne 电子邮件活动处理来自 Microsoft Exchange 2013 上托管的用户邮箱或日记邮箱的邮件时,您会看到在处理某些邮件时遇到的错误。根据作业所属的活动类型,影响会有所不同。以下是一些示例:
  • 如果是日记活动,电子邮件将被移动到日记邮箱的“已发送邮件”文件夹中。当这些项目移回“收件箱”文件夹时,它们将再次移回“已发送邮件”文件夹。
  • 对于“存档 - 历史”和“快捷方式 - 历史”活动,在处理邮箱期间会遇到错误。有时,在出现几次错误后,SourceOne 服务帐户将无法登录到邮箱,因此将跳过邮箱。下一个邮箱将继续处理,而不会出现问题。由于未正确处理邮箱,作业将标记为“失败”状态。
以下是将记录在 SourceOne 详细日志中的错误示例: 
  1. 当无法处理以下消息时:“Shortcut - Historical”活动,日志文件名ExShortcutJBC.exe.log,并将位于本应处理作业的 SourceOne 工作服务器上。
360|货号:P20A4|T3110|2017/03/15 20:16:20:968|CoExExchMsg::CacheProps|错误 |无法从 MsgId 中提取 MAPI 属性: xxxxx xxxxxx/\Inbox\/RE:Test 电子邮件 (0x86040C02) 未指定的错误 (0x80004005) [ExShortcutJBC.exe,CoExExchMsgProps.cpp(554)。CoExExchMsg::CacheProps] |CoExExchMsgProps.cpp(554)|作业 ID:468076;活动名称:TestActivity 快捷方式活动;活动 ID:158;活动类型:14个;ES1WORKER395|货号:P20A4|T6E0|2017/03/15 20:16:31:374|CExExchMsgIdEx::CalcMsgIdUsingSchema|错误 |系统调用失败。(0x86040100) 函数调用:HrQueryAllRows,失败。(0x8604013D)[ExShortcutJBC.exe,ExExchMsgIdEx.cpp(510)。CExExchMsgIdEx::GetRecipientsIdValue] >无法创建邮件副本,MsgId: xxxxx xxxxxx/\Inbox\/RE:测试电子邮件 (0x86040C08) 不明错误 (0x80004005) [ExShortcutJBC.exe, CoExExchMsg.cpp(740).CoExExchMsg::P repareMemoryMsg] [ExShortcutJBC.exe,ExExchMsgIdEx.cpp(510)。CExExchMsgIdEx::GetRecipientsIdValue] |ExExchMsgIdEx.cpp(196)|作业 ID:468076;活动名称:TestActivity 快捷方式活动;活动 ID:158;活动类型:14个;ES1WORKER
400|货号:P20A4|T23E0|2017/03/15 20:18:12:551|CoExExchMsg::P repareMemoryMsg|错误 |无法创建消息副本,MsgId:Rajan Katwal/\收件箱\/回复:测试消息(0x86040C08) 未指定错误(0x80004005)|CoExExchMsg.cpp(740)|作业 ID:468078;活动名称:TestActivity 快捷方式活动;活动 ID:158;活动类型:14;ES1WORKER 


  1. 在处理邮箱的中途丢失对邮箱的访问时,遇到的错误与上面提到的错误类似,还发现了以下内容:“Shortcut - Historical”活动,日志文件名ExShortcutJBC.exe.log,并将位于本应处理作业的 SourceOne 工作服务器上。 
104|P18CC|T694|2017/04/09 21:30:30:920|CExJBMBoxTasks::OpenFolder|ERROR-LOGD|无法打开文件夹:\Inbox\xxxxxx,邮箱:/o=Exchange Organization/ou=First Administrative Group/cn=Recipients/cn=xxxxxx (0x86041E01) [ExShortcutJBC.exe, CoExExchProvFolder.cpp(767).CoExExchProvider::OpenFolder]   >System call failed.(0x86040100) 未指明的错误 (0x80004005) [ExShortcutJBC.exe, CoExExchFolder.cpp(194).CoExExchFolder::OpenFolder] |CExJBMBoxTasks.cpp(690)|作业 ID:518112;活动名称:TestAcivity 快捷方式活动;活动 ID:154;活动类型:14个;在处理具有“存档 - 历史”和“日记”活动的邮箱时,也会看到类似于上述的 ES1Worker 
错误消息。

遇到上述错误时,类似于以下内容的错误将记录在 Microsoft Exchange Server 的“应用程序”事件日志中:
 
Log Name:      应用
源:        MSExchange 通用
日期:          4/9/2017 9:30:32 PM
事件 ID:      4999
任务类别:常规
水平:         错误
关键字:      经典
用户:          不适用
计算机:      xxxxxxxx.xxxxxx.local
描述:
即将发送的 Watson 报告获取进程 ID:10088,参数:E12, c-RTL-AMD64, 15.00.1130.007, M.E.RpcClientAccess.Service, 未知, M.E.D.T.I.F.F.TextStore.AddText, System.IndexOutOfRangeException, 交流, 未知。
ErrorReportingEnabled:False 




 

原因

此问题是由 TextConverter 类中出现的逻辑错误引起的,当 TextConverter 在 Microsoft Exchange Server 上执行缓冲区复制作时。

有关更多详细信息,请访问 https://support.microsoft.com/en-us/help/3061079/rpc-client-access-service-crashes-and-event-4999-is-logged-in-exchange-server-2013

解决方案

若要解决此问题,请安装 Exchange Server 2013 的累积更新 14 或更高版本。

受影响的产品

SourceOne Email Management

产品

SourceOne, SourceOne Email Management
文章属性
文章编号: 000055223
文章类型: Solution
上次修改时间: 10 9月 2025
版本:  6
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。