XtremIO X2:在运行 XIOS 6.3.0-62 的群集上,从 Solaris 或 AIX 主机发出 SCSI RELEASE 命令后数据不可用

摘要: 本知识库文章处理与 Solaris 或 AIX 主机有关的 XtremIO X2 XIOS 6.3.0-62 面临的 DU 情况。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

连接到 XtremIO X2 群集的 Solaris 或 AIX 主机正在重新启动。
新主机分区作在连接到 XtremIO X2 群集的 Solaris 主机上完成。 
 
在具有运行 XIOS 软件版本的 XtremIO 群集的 Solaris 或 AIX 连接主机上,任何涉及 SCSI 设备发现的作 都可能导致 XtremIO 群集停止其服务。
 

提醒:此问题不会影响 XtremIO X1 群集。
提醒:此问题不会影响连接到非 Solaris 或 AIX 主机的群集。
提醒:此问题 不会影响XIOS S/W 版本低于 6.3.0-62 的群集。


此类作的示例包括:   

 

  • Solaris 或 AIX 主机重新启动连接到运行 XIOS S/W 版本 6.3.0-62 的 XtremIO 群集
  • 新的 Solaris 或 AIX 主机分区到运行 XIOS S/W 版本 6.3.0-62 的 XtremIO 群集

原因

在运行 XIOS S/W 版本 6.3.0-62 的 XtremIO 群集上,当向存储阵列控制器设备 (SACD) 发送 SCSI RELEASE (SCSI2) 命令时,处理该命令的 XtremIO 软件 I/O 模块 (XENV) 将重新启动。XENV 重新启动流程需要几秒钟才能完成,并且应该不会影响群集服务。

在主机启动器和存储阵列目标端口之间执行分区(或等效的 iSCSI)作后,SACD 设备通常向具有 LUNID 0 (LUN0) 的外部主机公开。虽然外部主机不会为 SACD 设备发送 SCSI RELEASE 命令,但已发现 SOLARIS OS 正在为所有新发现的 SCSI 设备(包括 SACD 设备)发送 SCSI RELEASE 命令。

显然,当 Solaris 或 AIX 主机由于 XENV 重新启动而在几秒钟内未遵循 SCSI RELEASE 命令从 XtremIO 存储阵列获得回复时,该命令会超时,并且主机会再次发送 SCSI RELEASE 命令。

此重复流 可能会导致 XtremIO 存储阵列中出现滚动高可用性 (HA) 事件,从而导致群集停止其服务。

解决方案

此问题的永久修复包含在 XIOS 版本 6.3.1-5(或更高版本)中。为避免在使用(或考虑使用)XIOS 版本 6.3.0-62 时出现此问题,强烈建议升级到版本 6.3.1-5(或更高版本)。请联系 Dell Technologies 全球技术支持,以安排此版本的群集软件更新 (NDU)。请指定 Dell Technology KB# 541318(本文)以加快此请求的处理速度。

*在本文所述的问题上,群集会自动恢复其服务。

对于 Solaris 主机:   
Solaris 主机可能会多次遇到此问题。因此,建议在 XIOS 6.3.1-5 或更高版本可用之前执行以下步骤作为解决方法:

  1. 暂时删除 Solaris 主机的分区。
  2. 如果 XtremIO 存储阵列已升级到 XIOS S/W 版本 6.3.0-62,则可以应用解决方法将 LUNID 为 0 的虚拟卷映射到 Solaris 主机。
这可确保 SACD 设备不会呈现给主机,因此不会向其发送 SCSI RELEASE 命令。
  1. 如果必须将新的 Solaris 主机连接到群集,请手动创建主机启动器组,并且不要使用自动发现功能。此外,在主机上执行任何分区或发现作之前,使用 LUNID 0映射虚拟卷。
如本文的原因部分所述,SACD 设备在分区作后直接呈现给主机,甚至在 XtremIO 阵列端创建启动器组之前也是如此。因此,这是防止 SACD 暴露给主机以及向此设备发送 SCSI RELEASE 命令的唯一方法。
  1. 重新添加在此过程的步骤 1 中临时删除的 Solaris 主机的分区
  2. 最后,强烈建议尽快升级到 6.3.1-5(或更高版本)以永久解决此问题


对于 AIX 主机:   

  1. 确保您的 AIX 主机配置为“no_reserve”
  2. 永久修复方法是升级到 XIOS 6.3.1-5 或更高版本(一旦可用)。

受影响的产品

XtremIO X2

产品

XtremIO Family, XtremIO X2
文章属性
文章编号: 000058573
文章类型: Solution
上次修改时间: 06 10月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。