OpenManage Enterprise:删除 Services 插件后无法重新创建插件程序组
摘要: 利用 API 创建和删除 Services 插件组的客户发现,如果他们利用 OpenManage Enterprise (OME) GroupService API (GroupService/Groups(#)) 删除插件组,则 Services 插件组将无法再管理,并且由于“组已存在”错误而无法重新创建。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
使用 OpenManage Enterprise (OME) GroupService/Groups API 删除 Services 插件程序组会导致无法再使用 Web UI 或 Services 插件程序创建或更新组 API 创建组。
从 Web UI 重新创建组会显示错误“无法创建或更新组”。
使用服务插件程序 API 重新创建组(POST /api/SupportAssistService/Actions/SupportAssistService.CreateOrUpdateGroup) 返回以下 500 响应:
{
"error": {
"code": "Base.1.0.GeneralError",
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"MessageId": "CGEN6001",
"RelatedProperties": [],
"Message": "Unable to process the request because an error occurred: SAE-020100 : A group with this name already exists. Change the name of this group, then try again..",
"MessageArgs": [
"SAE-020100 : A group with this name already exists. Change the name of this group, then try again."
],
"Severity": "Critical",
"Resolution": "Retry the operation. If the issue persists, contact your system administrator."
}
]
}
}
原因
服务插件利用单独的 SDK 数据库来存储基于插件的数据,如设备资源清册和组数据。创建 Services 插件程序组时,详细信息将使用唯一的组 UID 存储在 SDK 数据库中,然后使用组 ID 将 OpenManage Enterprise (OME) 组信息传播到 OpenManage Enterprise (OME) 数据库中。
这两个 ID 使用 supportassist.group_saegroup_association 表中,以及使用 OpenManage Enterprise (OME) 删除组时 GroupService API 删除不会滚动到 SDK 数据库中,留下孤立条目。
解决方案
戴尔工程部门已意识到此问题,并将在未来版本的 Services 插件中提供修复。
在此之前,客户只能利用服务插件 API 来创建、管理和删除插件组。
如果客户无法重新创建以前删除的组,请升级到 DE 或 IPS,因为需要 FSD 清理 Services 插件程序 SDK 数据库中的孤立组。
受影响的产品
OpenManage Enterprise Services, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640
, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
文章属性
文章编号: 000215072
文章类型: Solution
上次修改时间: 09 9月 2025
版本: 2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。