OpenManage Enterprise:4.0 迁移失败,并显示“无法解密备份和归档”
摘要: 在某些迁移情形中,OpenManage Enterprise 4.0 目标导入作可能会在迁移期间失败,并显示错误“无法解密备份归档”。使用以下文章可帮助对此方案进行故障处理,并提供解决故障的各种方法。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
从目标开始“迁入”后不久,导入似乎突然停止,并显示登录屏幕。
重新登录到 Web 用户界面后,将显示以下黄色横幅:
单击 “View Logs ”链接将显示导入作业详细信息,并看到以下错误:
重新登录到 Web 用户界面后,将显示以下黄色横幅:
Last Import job failed. Click on view logs for details.
单击 “View Logs ”链接将显示导入作业详细信息,并看到以下错误:
Unable to decrypt the backup file. Please check the provided encryption passphrase. Failed to perform import task.

原因
在几种情况下,迁移导入作可能会失败并出现解密错误。它们如下:
- 情况 1:导出文件之间的哈希比较失败
- 情况 2:“迁入”作期间使用的密码短语不正确
解决方案
要更好地了解导致解密错误的原因,请首先从 OpenManage Enterprise 版本 4.0(目标)Web 界面下载控制台日志包。
- 浏览到 监视 ->故障处理 ->日志。
- 单击“Generate Log” 按钮,等待日志收集作业完成。
- 日志包可用后,单击 “Download Log”,然后将压缩文件保存到本地位置。
- 提取 控制台日志包。
- 完成解压后,浏览至。
\backuprestoreservice文件夹,然后打开ome_encryption_decryption.log文件。
情况 1:哈希比较失败:
随着 ome_encryption_decryption 日志文件打开时,如果源设备和目标设备之间的备份文件校验和不匹配,则会显示以下错误。
2024.01.05-21:20:09 ome_backup_encryption - error: Hash comparison failed
如果日志中显示此错误, 请将目标设备更新到版本 4.0.1,然后重试迁移。
情况 2:在“迁入”作期间使用了不正确的密码:
随着 ome_encryption_decryption 日志文件打开时,如果在目标设备上输入了不正确的密码,则会显示以下错误。
2024.01.25-15:44:02 ome_backup_encryption - Decryption command result -> 2
加密源备份文件期间使用此密码。必须在目标设备上使用相同的密码来解密备份文件。
- 从源设备中,浏览到 备份-还原 ->迁移 - 迁出,然后 展开 步骤 4。
- 单击 “Abort Migration” 链接以取消迁移,并将源设备恢复到 READY 状态。
- 从 步骤 3 开始重新启动迁移作,并确保源设备上使用的密码与在目标设备上为“迁入”作输入的密码相同。
在目标设备上迁移期间成功解密源文件会显示 结果代码 0:
2024.01.05-21:20:09 ome_backup_encryption - Decryption command result -> 0
受影响的产品
Dell EMC OpenManage Enterprise产品
C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions文章属性
文章编号: 000221490
文章类型: Solution
上次修改时间: 06 5月 2025
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。