NativeEdge:对 NativeEdge Orchestrator 中重置恢复映像上传停止的问题进行故障处理
摘要: 本文有助于对 NativeEdge 端点的重置或恢复映像期间停滞或停止响应上传的原因进行故障处理。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
在创建 NativeEdge 端点的重置或恢复映像时,下载进度条不可用,并且长时间没有进度。
原因
检查 fru-cru pod 如下所示:
# kubectl get pods -A | grep fru-cru hzp hzp-fru-cru-svc-5fc46f884-5qv9p 2/2 Running 0 15d # kubectl logs hzp-fru-cru-svc-5fc46f884-5qv9p | grep "\/usbimage\/ENDPOINT_TAG"
提醒:替代
ENDPOINT_TAG 替换为您尝试为其下载重置映像的端点的标签。
如果您在输出中看到如下消息,这意味着您的基础架构中的某些内容阻止了文件下载。
[2025-04-14T12:14:26.600Z] "GET /api/v2/usbimage/ENDPOINT_TAG/reset HTTP/1.1" 200 DC downstream_remote_disconnect - "-" 0 32280362 1022292 6931 "172.18.141.2,161.200.40.200" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:137.0) Gecko/20100101 Firefox/137.0" "dad3e8ec-9330-4015-ab09-45821fa89f74" "internal.dns.name.net" "161.200.40.236:8080" inbound|8080|| 127.0.0.6:33941 161.200.40.236:8080 161.200.40.200:36306 outbound_.80_._.hzp-fru-cru-svc.hzp.svc.cluster.local default
解决方案
基础架构可能阻止映像下载的常见原因包括:
- 浏览器超时设置
- 防火墙
- 防病毒
- 安全扩展程序终止大型或慢速下载
此外,这可能是中间代理或负载均衡器:浏览器和 NativeEdge 的 Istio 入口网关之间的网络设备、反向代理或防火墙超时连接,这些连接超过特定持续时间或大小阈值。
在这种情况下尝试的最常见选项是:
- 尝试使用其他浏览器下载
- 尝试下载另一台客户端计算机
- 与管理员或安全管理员一起检查内部安全规则(文件流限制、内部文件传输:防火墙、防病毒软件或浏览器扩展程序)
如果您无法解决问题,请联系 戴尔支持。
受影响的产品
NativeEdge文章属性
文章编号: 000312858
文章类型: Solution
上次修改时间: 14 5月 2025
版本: 1
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