PowerEdge:BIN 文件更新无法识别 NVIDIA ConnectX-4 和 ConnectX-5 卡

摘要: 本文提供了 ConnectX-4 LX NIC SWB 76DNG 版本 14.32.21.02 和 ConnectX-5 双端口 SWB 1GF8G 版本 16.35.40.30 的固件更新错误的解决方案。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

在运行 Red Hat 8 和 9 的 14G 平台上,使用 Mellanox ConnectX-4 LX NIC SWB 76DNG 版本 14.32.21.02 和 ConnectX-5 双端口 SWB 1GF8G 版本 16.35.40.30 的 BIN 文件更新固件失败。

更新过程返回错误: “No relevant image file was found for this device.”


错误输出 


错误输出 
此问题会影响 CX-4 和 CX-5 BIN 文件的固件合规性和更新策略。

原因

BIN 文件更新包在执行过程中无法正确识别 Mellanox NIC 设备,导致无法找到相应的映像文件。此问题似乎特定于较新的更新版本,并会影响通过作系统执行的更新。

解决方案

问题已在以下已发布版本中得到解决:

CX-4 固件版本 14.32.21.04_A00_03

CX-5 固件版本 16.35.45.54_A00_01

解决方法选项。

1.使用 iDRAC
2 更新。RACADM CLI 更新
3。作系统 — 手动提取 DUP 并使用 mlxfwupdater 应用固件:

提醒: mlxfwupdater 是较新驱动程序中的 MFT(NVIDIA 固件工具)的一部分。如果缺少 MFT,请使用 NVIDIA 支持站点找到 MFT 资源。 

Shell
Step 1: ./NameOfDUP --extract <NameDirectoryToExtractTo i.e update>
Step 2: cd <DirectoryToExtractTo>./mlxfwupdater -D payload -u -y

即 ConnectX-4 LX。 

CLI 输出

如果同一系统中存在两个适配器,则执行以下作:

  1. 在解压的目录之间复制有效负载固件文件
  2. 运行更新程序以将更新应用到所有适配器。

 

 

 

受影响的产品

Mellanox Family of Adapters, PowerEdge C4130, Poweredge C4140, PowerEdge c6300, PowerEdge c6320, PowerEdge c6320p, PowerEdge C6420, Poweredge FC430, Poweredge FC630, PowerEdge FC640

产品

Poweredge FC830, PowerEdge M630, PowerEdge M630 (for PE VRTX), PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M830, PowerEdge M830 (for PE VRTX), PowerEdge MX740C, PowerEdge MX840C, PowerEdge R340, PowerEdge R430, PowerEdge R440 , PowerEdge R530, PowerEdge R540, PowerEdge R630, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R660, PowerEdge R6615, PowerEdge R6625, PowerEdge R730, PowerEdge R730xd, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R7525, PowerEdge R760, PowerEdge R7615, PowerEdge R7625, PowerEdge R830, PowerEdge R840, PowerEdge R930, PowerEdge R940, PowerEdge R940xa, PowerEdge T430, PowerEdge T630, PowerEdge T640, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XR4520c ...
文章属性
文章编号: 000378312
文章类型: Solution
上次修改时间: 02 2月 2026
版本:  6
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。