エージェントがNullReferenceExceptionを使用してサーバーに登録できない
摘要: エージェントが、ログにNullRefernceExceptionを使用してDell Security Management Serverに登録できない。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
対象製品:
- Dell Endpoint Security Suite Enterprise
- Dell Endpoint Security Suite Pro
エンド ユーザーは、Advanced Threat Preventionがアクティブ化されておらず、次の下のDellAgentログ ファイルをチェックしていることに気付きました。
C:\ProgramData\Dell\Dell Data Protection
次のエラー メッセージが表示されます。
2017.08.18 10:07:31 I Comm : Registering agent on server... 2017.08.18 10:07:31 E Comm : general exception - System.NullReferenceException: Object reference not set to an instance of an object. at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.RegisterAgent(IAgentService proxy) at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.ContactServer(String serverUri, Int32& SleepSecs) at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.OnPluginProcess()
原因
-
解析度
注意:表示されているエラー メッセージが正確である場合にのみ、次の手順を実行します。問題でない場合は悪影響を及ぼす可能性があります。
注:管理者特権のコマンド プロンプトから次のコマンドを実行します。
WMI リポジトリを確認するには、次のコマンドを実行します。
winmgmt /verifyrepository
整合性がない場合は、次のコマンドを実行します。
winmgmt /salvagerepository
システム トレイの Dell Data Security アイコン を右クリックし、 Check for Policy Updates を選択すると、エージェントが登録され、数分後 に Advanced Threat Prevention が緑色になります。
サポートに問い合わせるには、「Dell Data Securityのインターナショナル サポート電話番号」を参照してください。
TechDirectにアクセスして、テクニカル サポート リクエストをオンラインで生成します。
さらに詳しい情報やリソースについては、「デル セキュリティ コミュニティー フォーラム」に参加してください。
其他資訊
受影響的產品
Dell Endpoint Security Suite Pro, Dell Endpoint Security Suite Enterprise文章屬性
文章編號: 000124791
文章類型: Solution
上次修改時間: 04 1月 2024
版本: 7
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。