Aracı, NullReferenceException ile sunucuya kayıt başarısız oluyor

摘要: Aracı, günlükte NullRefernceException ile Dell Security Management Server'a kaydolmaz.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Etkilenen Ürünler:

  • Dell Endpoint Security Suite Enterprise
  • Dell Endpoint Security Suite Pro

Son kullanıcı, Advanced Threat Prevention'ın etkin olmadığını fark ediyor ve aşağıdakiler altındaki DellAgent günlük dosyalarını kontrol ediyor:

C:\ProgramData\Dell\Dell Data Protection

Aşağıdaki hata mesajını fark edin:

2017.08.18 10:07:31 I Comm : Registering agent on server...
2017.08.18 10:07:31 E Comm : general exception - System.NullReferenceException: Object reference not set to an instance of an object.
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.RegisterAgent(IAgentService proxy)
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.ContactServer(String serverUri, Int32& SleepSecs)
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.OnPluginProcess()

原因

Geçerli Değil

解析度

Dikkat: Sorun bu değilse olumsuz etkilere neden olduğundan bu adımları yalnızca, tam olarak görüyorsanız gerçekleştirin.
Not: Yükseltilmiş komut isteminden aşağıdaki komutları çalıştırın.

WMI depoyu kontrol etmek için bu komutu çalıştırın:

winmgmt /verifyrepository

Tutarsız olduğu bulunduysa şu komutu çalıştırın:

winmgmt /salvagerepository

Sistem tepsisindeki Dell Data Security simgesine sağ tıklayın ve İlke Güncelleştirmelerini Denetle öğesini seçin, aracı kayıt olur ve birkaç dakika sonra Advanced Threat Preventionyeşile döner.


Destek ile iletişime geçmek için Dell Data Security Uluslararası Destek Telefon Numaraları başlıklı makaleye başvurun.
Çevrimiçi olarak teknik destek talebi oluşturmak için TechDirect adresine gidin.
Daha fazla faydalı bilgi ve kaynak için Dell Security Topluluk Forumu'na katılın.

其他資訊

 

受影響的產品

Dell Endpoint Security Suite Pro, Dell Endpoint Security Suite Enterprise
文章屬性
文章編號: 000124791
文章類型: Solution
上次修改時間: 04 1月 2024
版本:  7
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。