PowerEdge:vSphere H5 用戶端中的 AD 使用者密碼到期警示
摘要: vCenter 啟用 Active Directory (AD) 並讓 Active Directory 使用者登入時收到「密碼將在 X 天後到期」的通知,客戶必須將其清除。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
- Active Directory 使用者的 vCenter 登入通知「密碼將在 26 天後到期」

- 如果交換至系統管理員使用者登入 vCenter,則不會收到「密碼將在 X 天後到期」的通知

原因
Active Directory 密碼到期通知與 vCenter Server SSO 密碼到期是分開的。Active Directory 使用者的預設密碼到期通知為 30 天,但密碼到期時間取決於您的 Active Directory 系統。vSphere Client 可控制到期通知。您可以更改預設到期通知以滿足公司的安全標準。
解析度
- SSH 登入 vCenter Server CLI
- 將目錄變更為 vSphere 用戶端的位置
webclient.propertiesfile注意:5Client - /etc/vmware/vsphere-ui/webclient.propertiescd /etc/vmware/vsphere-ui
- 使用文字編輯器開啟 webclient.properties 檔案
vim /etc/vmware/vsphere-ui/webclient.properties
- 編輯以下變數,
sso.pending.password.expiration.notification.days = 30 -a 5
- 重新啟動 vSphere 用戶端
service-control --stop vsphere-uiservice-control --start vsphere-ui
- vCenter 由Active Directory 使用者再次登入,通知「密碼將在 26 天後到期」不見
了 請參閱文件和 KB:
VMware vSphere 7.0 產品說明文件
https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.authentication.doc/GUID-861C3140-A9AE-42A5-83EF-BC2CCEA9E4C7.html
在 vSphere Web/H5 用戶端
中為 Active Directory 使用者變更「密碼將於 X 天後到期」通知https://williamlam.com/2017/11/changing-password-will-expire-in-x-days-notification-for-active-directory-users-in-vsphere-web-h5-client.html
受影響的產品
Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M7701, PowerEdge M7725
, PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R250, PowerEdge R350, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, VMware Carbon Black, VMware ESXi 8.x, VMware ESXi 9.x, VMware OEM Products with ProSupport, VMware VSAN
...
文章屬性
文章編號: 000192597
文章類型: Solution
上次修改時間: 16 2月 2026
版本: 3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。