PowerStore: Po uaktualnieniu PowerStore do wersji 2.0.x.x lub 2.1.x.x woluminy nie są dostępne dla połączonych bezpośrednio hostów FC

摘要: Po uaktualnieniu PowerStore do wersji 2.0.x.x lub 2.1.x.x połączone bezpośrednio hosty ze sterownikami zgodnymi z NVMe mogą utracić dostęp do wszystkich woluminów.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Host może utracić dostęp do woluminów po uaktualnieniu PowerStore do wersji, której dotyczy problem.
Jeśli PowerStore został uaktualniony wcześniej do wersji, której dotyczy problem, aktualizacja sterowników hosta do wersji zgodnej z NVMe uwidocznia ten problem.

原因

Po zaktualizowaniu hostów do obsługi NVMe może nastąpić drugi proces logowania (PRLI) z hosta po każdym zdarzeniu łączenia. Ten drugi interfejs PRLI jest przeznaczony do transportu NVMe, a PowerStore nie obsługuje tego drugiego interfejsu PRLI optymalnie.

解析度

Ten problem zostanie naprawiony w przyszłej wersji PowerStoreOS.
Aby obejść problem, należy wyłączyć obsługę NVMe w sterowniku.

 

Hosty ESXi — patrz artykuł z bazy wiedzy VMware: 84325. Podsumowanie poniżej.
 
ESXi korzystający z Qlogic lub Marvel HBA i sterownika qlnativefc:
esxcfg-module -s 'ql2xnvmesupport=0' qlnativefc
 
ESXi korzystający z Emulex HBA i sterownika lpfc:
esxcli system module parameters set -m lpfc -p lpfc_enable_fc4_type=1
 
 
Hosty Red Hat — patrz artykuł z bazy wiedzy: 3522911. Podsumowanie poniżej.
 
Host Linux korzystający z Qlogic lub Marvel HBA i sterownika qlnativefc — dodaj lub edytuj poniższy wiersz:
vi /etc/modprobe.d/qla2xxx.conf
ql2xnvmeenable=0
 
Host Linux korzystający z Emulex HBA i sterownika lpfc — edytuj poniższy plik i dodaj lub edytuj poniższy wiersz:
vi /etc/modprobe.d/lpfc.conf
 lpfc lpfc_enable_fc4_type=1

Hosty muszą zostać uruchomione ponownie po zmianie konfiguracji sterownika HBA.

受影響的產品

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
文章屬性
文章編號: 000200588
文章類型: Solution
上次修改時間: 14 6月 2023
版本:  14
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。